[Flame][Homescreen]The "Close" and "OK" button is shown incompletely on operator message view.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: apastor)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Posted image issue.png
[1.Description]:
[Flame][v2.2&v3.0][Homescreen]Both the "Close" and "OK" button show incompletely on operator message view in Gallery app.
Found at:15:14
see attachments:logcat.txt, issue.png.

[2.Testing Steps]: 
Premise:insert SIM card.
1.Launch Gallery .
2.Turn on airplane mode.
3.Turn off airplane mode and wait for the operator message.


[3.Expected Result]: 
3.The "Close" and "OK" button is shown completely.

[4.Actual Result]: 
3.The "Close" and "OK" button is shown incompletely on operator message view.


[5.Reproduction build]: 
Flame 2.2:(Affected)
Build ID               20150324002504
Gaia Revision          014d38f7ad3912b8b33cb08ce7535a5dc5aced59
Gaia Date              2015-03-23 23:27:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a9f2a248e57
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.041652
Firmware Date          Tue Mar 24 04:17:03 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0:(Affected)
Build ID               20150324160206
Gaia Revision          aebfbd998041e960cea0468533c0b5041b504850
Gaia Date              2015-03-24 17:08:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/264387e7e453
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150324.193523
Firmware Date          Tue Mar 24 19:35:34 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
The pop-up operator message also shows incompletely on camera or video interface.
(Reporter)

Comment 1

4 years ago
Posted file logcat.txt
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Whiteboard: [systemsfe]
Broken UI
blocking-b2g: --- → 2.2+
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Updated

4 years ago
Attachment #8583884 - Flags: review?(kgrandon)
Comment on attachment 8583884 [details] [review]
[gaia] albertopq:1147324-stk-fullscreen > mozilla-b2g:master

LGTM, thanks.
Attachment #8583884 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#bbeUNTwGRqGC_EcuMb_m5g

The pull request failed to pass integration tests. It could not be landed, please try again.
(In reply to Autolander from comment #5)
> http://docs.taskcluster.net/tools/task-graph-inspector/
> #bbeUNTwGRqGC_EcuMb_m5g
> 
> The pull request failed to pass integration tests. It could not be landed,
> please try again.

Looks like this is a real lint error with the test file.
(Assignee)

Comment 7

4 years ago
Yeah, I already fixed it while adding your comment. Thanks!
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(apastor)
Target Milestone: --- → 2.2 S9 (3apr)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8583884 [details] [review]
[gaia] albertopq:1147324-stk-fullscreen > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: STK messages are shown truncated on fullscreen apps
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Low risk patch. Changing css through JS, with unit tests.
[String changes made]: none
Flags: needinfo?(apastor)
Attachment #8583884 - Flags: approval-gaia-v2.2?
Attachment #8583884 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been successfully verified on Flame 3.0
Reproducing rate: 0/5
Flame 3.0:
Build ID               20150327160203
Gaia Revision          9cc496cecc37d7a29f9279827cdf6e4891211f67
Gaia Date              2015-03-27 13:55:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/44e454b5e93b
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.192632
Firmware Date          Fri Mar 27 19:26:42 EDT 2015
Bootloader             L1TC000118D0
leave verifyme for following 2.2 landing
Keywords: verifyme

Comment 14

4 years ago
This issue verified successfully on flame 2.2:
Flame 2.2:
Build ID               20150331002503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate         0/5
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

4 years ago
Per comment 14, clear the verifyme keyword.
QA Whiteboard: [MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.