Flex item with aspect ratio & "max-width" still renders with native height

VERIFIED DUPLICATE of bug 1030952

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 1030952
3 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8583247 [details]
testcase 1

STR: Load attached testcase.

EXPECTED RESULTS: Image renders, scaled down naturally to a (small) wider-than-tall rectangular area.

ACTUAL RESULTS: Image renders, squashed, to a taller-than-wide rectangular area.


NOTES:
* The image's native resolution is 400px wide & 200px tall.
* The image's width is horizontally constrained via "max-width: 150px".
* The image's height isn't directly constrained.

Chrome & Opera 12.16 (Presto) give EXPECTED RESULTS. Firefox Nightly gives ACTUAL RESULTS.

I'm filing this for a bug that was emailed to me - I'm not 100% sure what the spec requires of this scenario yet, but I'm pretty sure our rendering is wrong.
(Reporter)

Updated

3 years ago
Summary: Flex item with aspect ratio & shrunken width still renders with native height → Flex item with aspect ratio & "max-width" still renders with native height
(Reporter)

Updated

3 years ago
Attachment #8583247 - Attachment description: test-flex.html → testcase 1
(Reporter)

Comment 1

3 years ago
Pretty sure this is a dupe of bug 1030952, actually.  A quick check in GDB shows that the problem described in bug 1030952 comment 2 is still happening here.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030952
(Reporter)

Comment 2

2 years ago
I verified that this bug's testcase produces EXPECTED RESULTS in latest Nightly 49.0a1 (2016-05-02) (which has the duplicate-target bug's fix).
 --> Verified duplicate
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.