Closed Bug 1147612 Opened 5 years ago Closed 5 years ago

[Dialer] SIM picker screen for dialer is not translated in any language

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: bzumwalt, Assigned: gduan)

References

Details

(Keywords: l12y, regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Attached image Screenshot
Description:
With two SIM cards in device, all text on SIM picker screen on dialer is displayed in English no matter what language the phone is set to (e.g. French, Italian, or Arabic.)

Repro Steps:
1) Update a Flame to 20150325010206
2) Set language to French
3) Launch Dialer
4) Dial any number and then long press the dial button

Actual:
All text on SIM picker page is in English.

Expected:
All text on SIM picker page is properly translated.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150325010206
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: cc0950b7a369
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 3/3, 100%
See attached: screenshot
Issue does NOT reproduce in Flame 2.2

All text on SIM picker page is properly translated.

Device: Flame 2.2
Build ID: 20150325002503
Gaia: aeee2a54caa8ffb875b96264b61d742b70689f22
Gecko: 556aca3e50ac
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
[Blocking Requested - why for this release]:

This is a regression from 2.2 and these strings are broken on all languages so nominating this 3.0?
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: bzumwalt
Thanks for filing this! I would say this depends on Bug 1147332 getting fixed, which causes many l10n stuff to appear broken in 3.0. But please verify once a fix lands there.
Thanks!
Depends on: 1147332
Keywords: verifyme
B2G-Inbound Regression Window:

Last working B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150313010516
Gaia: 891a7220030098865ccbc0fb2e2d591ebc347756
Gecko: cac083952284
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First broken B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150313015816
Gaia: 78d80e8138d7efdbac42453776a4bfa0f48bee59
Gecko: d0c157139a7e
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 891a7220030098865ccbc0fb2e2d591ebc347756
Gecko: d0c157139a7e

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: 78d80e8138d7efdbac42453776a4bfa0f48bee59
Gecko: cac083952284


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/891a7220030098865ccbc0fb2e2d591ebc347756...78d80e8138d7efdbac42453776a4bfa0f48bee59


Issue appears to have been caused by changes made in bug 1131515 (Delphines comment above jibes with info about bug 1147332 from comment 11)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Please recheck if this is still occurring on tomorrow's build.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bzumwalt)
triage: basic function broken
blocking-b2g: 3.0? → 3.0+
Issue does not reproduce on today's Flame 3.0

All text on SIM picker page is properly translated when long pressing dial button. Languages tested were Arabic, French, and Italian.

Device: Flame 3.0
Build ID: 20150327010205
Gaia: 249b8c08c1d57961ef6c905f3498fa62b032bf24
Gecko: e046475a75cb
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(bzumwalt) → needinfo?(ktucker)
Keywords: verifyme
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee: nobody → georgeiscoming
Target Milestone: --- → 2.2 S9 (3apr)
You need to log in before you can comment on or make changes to this bug.