inspector-cmdline.js isn't getting built any more

RESOLVED FIXED

Status

Other Applications
DOM Inspector
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
I wanted to start Thunderbird with DOM Inspector but I had to do it from the menu because the command line component wouldn't load. Tracing through the debugger I discovered that the component didn't ship with DOM Inspector 2.15, and furthermore the latest build of SeaMonkey that I could find with inspector-cmdline.js was 2.32 (Gecko 2.35); I built 2.33 (Gecko 2.36) and it didn't build that component.
(Reporter)

Comment 1

3 years ago
glandium pointed out on IRC that this is probably down to not porting bug 870370.
and bug 900526
(Reporter)

Comment 3

3 years ago
Created attachment 8584183 [details] [diff] [review]
Possible patch
Attachment #8584183 - Flags: review?(mh+mozilla)
Attachment #8584183 - Flags: review?(iann_bugzilla)
Attachment #8584183 - Flags: review?(mh+mozilla) → review+

Comment 4

3 years ago
Comment on attachment 8584183 [details] [diff] [review]
Possible patch

>+++ b/moz.build
>+
>+EXTRA_COMPONENTS += [
>+    'base/js/inspector-cmdline.js',
>+]
Is it worth moving inspector-cmdline.js to the root of the inspector repo or will this break things?

As a side question, is the moz.build under build/ correct? Can the install.js in that directory also be moved to the root?
Attachment #8584183 - Flags: review?(iann_bugzilla) → review+
(Reporter)

Comment 5

3 years ago
(In reply to Ian Neal from comment #4)
> Is it worth moving inspector-cmdline.js to the root of the inspector repo or
> will this break things?
We could move it, but I didn't see the point of adding extra history.

> As a side question, is the moz.build under build/ correct? Can the
> install.js in that directory also be moved to the root?
All that was obsoleted by bug 325100 when DOM Inspector became a non-binary extension, and support for Gecko prior to 1.9 was dropped.
(Reporter)

Comment 6

3 years ago
Pushed dom-inspector changeset e3b25cf3c256.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 7

3 years ago
(In reply to Ian Neal from comment #4)

> Can the
> install.js in that directory also be moved to the root?
The install.js can be removed since the DOMi doesn't support Firebird/Phoenix 0.8 or SeaMonkey 1.x or Netscape 6/7 or Thunderbird 0.8. You might want to file a new bug to remove install.js
You need to log in before you can comment on or make changes to this bug.