[Dialer] Answered call appears as missed call

RESOLVED FIXED in Firefox 40

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kanru, Assigned: aknow)

Tracking

({regression, smoketest})

unspecified
2.2 S10 (17apr)
All
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox40 fixed, b2g-v2.2 unaffected, b2g-master verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

4 years ago
STR:

 1. Having someone call you
 2. Answer the call
 3. Hang up

Expected result:
 No missed call

Actual result:
 Missed call notification, on the lock screen and in the call log
Reporter

Comment 1

4 years ago
Build ID               20150326010205
Gaia Revision          8dc256a2de273be3abfa2cb2103d872d677834f7
Gaia Date              2015-03-25 22:34:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d3dcbf23a9
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20140925.191337
Firmware Date          Thu Sep 25 19:13:47 EDT 2014
Bootloader             L1TC10011800
Repro'd on:

Build ID               20150326010205
Gaia Revision          8dc256a2de273be3abfa2cb2103d872d677834f7
Gaia Date              2015-03-25 22:34:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d3dcbf23a9
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.043801
Firmware Date          Thu Mar 26 04:38:10 EDT 2015
Bootloader             L1TC000118D0

QA wanted for a branch check.
This issue does NOT occur on Flame 2.2. Answered calls don't appear under Missed Call log.

Device: Flame 2.2 (full flash 319MB KK)
BuildID: 20150326002504
Gaia: e59ac067a1d22b7a72cbebc892ec652723f2a557
Gecko: 04b4b9d1faae
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Nominating this 3.0? since this a regression and bad from an end user's perspective.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: pcheng
blocking-b2g: --- → 3.0?
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150324184620
Gaia: 419b6873b4dc310e0099ba269dd5364985b76539
Gecko: 771b34ea0153
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150324201411
Gaia: 04924cd17fa7d6881c73e7d9a415410b0252cb9f
Gecko: 7690d9e5ba8a
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia & First Broken Gecko - issue DOES repro
Gaia: 419b6873b4dc310e0099ba269dd5364985b76539
Gecko: 7690d9e5ba8a

Last Working Gecko & First Broken Gaia - issue does NOT repro
Gaia: 04924cd17fa7d6881c73e7d9a415410b0252cb9f
Gecko: 771b34ea0153

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=771b34ea0153&tochange=7690d9e5ba8a

Caused by patches for Bug 1137093.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Szu-Yu, can you take a look at the please? This could have been caused by the landings for bug 1137093.
Blocks: 1137093
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(szchen)
Assignee

Updated

4 years ago
Assignee: nobody → szchen
Flags: needinfo?(szchen)
Attachment #8584270 - Flags: review?(htsai)
Assignee

Updated

4 years ago
Component: Gaia::Dialer → RIL
We should update the state first. Then set the |started| based on that.
Attachment #8584270 - Attachment is obsolete: true
Attachment #8584270 - Flags: review?(htsai)
Attachment #8584273 - Flags: review?(htsai)
Comment on attachment 8584273 [details] [diff] [review]
#2 Fix defect of setting call started time

Review of attachment 8584273 [details] [diff] [review]:
-----------------------------------------------------------------

Aknow, can you please help add a test case for this? We probably need to set navigator.mozSetMessageHandler for the system message "telephony-call-ended" and check the duration.
Attachment #8584273 - Flags: review?(htsai) → review+
triage: major regression, breaking basic function.
blocking-b2g: 3.0? → 3.0+
This also fails the smoketests, upgrading severity.
Keywords: smoketest
I've done the local test for the patch so land it first to avoid blocking the smoke test.

Now, I am working on a new marionette test for the issue. Please let the bug open and I'll land the test case later.
Keywords: leave-open
This issue is verified fixed in the latest Nightly Flame 3.0
Answered calls appear properly in the call log.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150330010204
Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gecko: dfe60814eda7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Assignee

Updated

4 years ago
Depends on: 1149433
Comment on attachment 8585982 [details] [diff] [review]
Test system message telephony-call-ended

Review of attachment 8585982 [details] [diff] [review]:
-----------------------------------------------------------------

It's really good to have this test, thank you.
Attachment #8585982 - Flags: review?(htsai) → review+
https://hg.mozilla.org/mozilla-central/rev/0a5f6d6035de
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S10 (17apr)
You need to log in before you can comment on or make changes to this bug.