ServiceWorkerRegistration::GetPushManager will fail on workers.

RESOLVED DUPLICATE of bug 1184574

Status

()

RESOLVED DUPLICATE of bug 1184574
3 years ago
3 years ago

People

(Reporter: dougt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
> +
> +
> +    JS::Rooted<JSObject*> jsImplObj(cx);
> +    nsCOMPtr<nsIGlobalObject> unused = ConstructJSImplementation(cx, "@mozilla.org/push/PushManager;1",
> +                              global, &jsImplObj, aRv);

This is going to fail miserably on workers when we expose ServiceWorkerRegistration on workers (Bug 1131327). Could you file a follow-up and add a comment with the bug number here?

The easy solution is that for workers we create a C++ PushManagerProxy that routes calls to their equivalents on the main thread (see DataStore comparison in dom/workers/DataStore.{h,cpp} and dom/datastore)
(Reporter)

Updated

3 years ago
No longer depends on: 1038811
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184574
You need to log in before you can comment on or make changes to this bug.