[e10s] responsivedesign/test/head.js causes unsafe CPOW usage warnings

RESOLVED DUPLICATE of bug 1235953

Status

DevTools
Responsive Design Mode
RESOLVED DUPLICATE of bug 1235953
3 years ago
a month ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [unsafe-cpow-usage])

Mined from test logs

In browser/devtools/responsivedesign/test/head.js:

https://hg.mozilla.org/projects/holly/file/50e197279ad5/browser/devtools/responsivedesign/test/head.js#l233

/**
 * Waits for the next load to complete in the current browser.
 *
 * @return promise
 */
function waitForDocLoadComplete(aBrowser=gBrowser) {
  let deferred = promise.defer();
  let progressListener = {
    onStateChange: function (webProgress, req, flags, status) {
      let docStop = Ci.nsIWebProgressListener.STATE_IS_NETWORK |
                    Ci.nsIWebProgressListener.STATE_STOP;
      info("Saw state " + flags.toString(16) + " and status " + status.toString(16));

      // When a load needs to be retargetted to a new process it is cancelled
      // with NS_BINDING_ABORTED so ignore that case
      if ((flags & docStop) == docStop && status != Cr.NS_BINDING_ABORTED) {
        aBrowser.removeProgressListener(progressListener);
        info("Browser loaded " + aBrowser.contentWindow.location); <-- causes unsafe CPOW usage warning
        deferred.resolve();
      }
    },
    QueryInterface: XPCOMUtils.generateQI([Ci.nsIWebProgressListener,
                                           Ci.nsISupportsWeakReference])
  };
  aBrowser.addProgressListener(progressListener);
  info("Waiting for browser load");
  return deferred.promise;
}
tracking-e10s: m8+ → ---
Whiteboard: [unsafe-cpow-usage]
This is test only.
tracking-e10s: --- → +

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235953

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.