Closed Bug 1148450 Opened 5 years ago Closed 5 years ago

Improve image preload performance

Categories

(Core :: ImageLib, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1148544

People

(Reporter: snorp, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached file Profile (obsolete) —
While profiling bug 857359, I'm finding that the nsHtml5TreeOpExecuter hogs a lot of main loop time. Of that, most of it seems to be consumed by preloading images. I narrowed it down to imgLoader::LoadImage(), but I'm not sure what's taking so much time there.
Could this move to some other thread than the main thread?
(In reply to Honza Bambas (:mayhemer) from comment #1)
> Could this move to some other thread than the main thread?

Not sure. imgLoader::LoadImage() does some stuff with a cache (simple hashtable), but mostly seems to just to open a channel.
These profiles would be more useful with stack walking, and symbolication.
Flags: needinfo?(snorp)
Attached file Better profile
You can see in this profile that much of the time is spent notifying HTTP observers when the request begins. Looks like this is a dup of bug 1148544.
Attachment #8584615 - Attachment is obsolete: true
Flags: needinfo?(snorp)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1148544
You need to log in before you can comment on or make changes to this bug.