Hitting "sync" button makes "back" button not to work properly

RESOLVED DUPLICATE of bug 1148900

Status

RESOLVED DUPLICATE of bug 1148900
4 years ago
4 years ago

People

(Reporter: fredy, Unassigned)

Tracking

({regression})

unspecified
2015Q1
x86_64
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0 s=bu.2015.5 [blocker])

Steps to reproduce:
1. Open BuddyUp app
2. Tap on "Answer Questions" button
3. Tap on "sync" button at the bottom
4. (Optional) Tap on Active tab
5. Tap on "back" button

Actual results:
If you clicked on active tab you return on new tab, if not then you stay on new tab.

Expected result:
Return to home page

Note: Tapping again on back button works fine.
Note 2: If you tap on sync button more than one times, you "disable" back button for the same times.
Note 3: It affects only the back button of "Answer a Question" list, if you go into a question back button works fine.
(Reporter)

Updated

4 years ago
Summary: Hitting "sync" button makes "back" button for one time not to work properly → Hitting "sync" button makes "back" button not to work properly
I believe this is a regression of bug 1137202 because I changed this to a <a> instead of a <button>
Depends on: 1137202
Keywords: regression
Indeed it is a regression of that commit.

Updated

4 years ago
Whiteboard: p=0 s=bu.2015.5 [blocker]
Target Milestone: --- → 2015Q1
This is being fixed by the patch in bug 1148900.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1148900
You need to log in before you can comment on or make changes to this bug.