[Search] After tapping the title bar in search engine selection view, it returns to home.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: apastor)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2&3.0][E.me Integration]Tap the title bar in search engine view, it return to home,then Launch Search again,It enters search engine view,and the keyboard pops up unexpectly.
Attchment:VIDEO0323_Compress.MP4 and logcat_1651.txt
Happen time:16:51

[2.Testing Steps]: 
1.Launch Search
2.Input some keywords
3.Tap search engine
4.Tap  the title bar in search engine view
5.Launch Search again

[3.Expected Result]: 
4.It will not return to Home

[4.Actual Result]: 
4.It return to home.
5.It enter search engine view,and the keyboard pops up unexpectly。

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0:  Affected
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Flags: needinfo?(hcheng)
Dale, could you take a look?
blocking-b2g: --- → 2.2?
Flags: needinfo?(hcheng) → needinfo?(dale)
After step 5 of STR, the search engine selection view would always pop up when there are some inputs in search app.
Summary: [Flame][E.me Integration]Tap the title bar in search engine view, it returns to home. → [Search] After tapping the title bar in search engine selection view, it returns to home.
Whiteboard: [systemsfe]
(Assignee)

Comment 4

4 years ago
I'll take a look :)
Assignee: nobody → apastor
Flags: needinfo?(dale)
(Assignee)

Updated

4 years ago
Attachment #8586011 - Flags: review?(kgrandon)
blocking-b2g: 2.2? → 2.2+
Component: Gaia::Everything.me → Gaia::Search
Comment on attachment 8586011 [details] [review]
[gaia] albertopq:1149116-search-title > mozilla-b2g:master

Seems fine to me. Thanks!
Attachment #8586011 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

4 years ago
Comment on attachment 8586011 [details] [review]
[gaia] albertopq:1149116-search-title > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: User goes back to the home after taping in the top screen.
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): We are making sure that is not a tap, before publishing the overlayopened event. Is a quite simple change, but we are renaming an event, so there is a small risk on that. We have added tests and all the previous ones are still passing, so should be fine.
[String changes made]: none
Attachment #8586011 - Flags: approval-gaia-v2.2?(bbajaj)
Keywords: verifyme
Attachment #8586011 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Reporter)

Comment 10

4 years ago
Verilfied on Flame 3.0. this issue still exist on flame 3.0, but there is some different behavior in new build ---->when I tap the title bar of Select search engine view, the search result view will flash, press home, tap search bar to envoke E.me again ,it will enter Select search engine view directly and the IME pops up unexpectly.
Flame 3.0:
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate         5/5
Video                  VIDEO0332_Compress.MP4
log                    logcat(11).txt
Happen time            5:05
Flags: needinfo?(echang)
(Reporter)

Updated

4 years ago
Keywords: verifyme
(Reporter)

Comment 11

4 years ago
(Reporter)

Comment 12

4 years ago
Posted file logcat(11).txt
Elie,

Could you open another bug for this flashing issue? It also affected 2.2.

(In reply to Elie from comment #10)
> Verilfied on Flame 3.0. this issue still exist on flame 3.0, but there is
> some different behavior in new build ---->when I tap the title bar of Select
> search engine view, the search result view will flash, press home, tap
> search bar to envoke E.me again ,it will enter Select search engine view
> directly and the IME pops up unexpectly.
> Flame 3.0:
> Build ID               20150401160204
> Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
> Gaia Date              2015-04-01 02:06:11
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
> Gecko Version          40.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Reproduce rate         5/5
> Video                  VIDEO0332_Compress.MP4
> log                    logcat(11).txt
> Happen time            5:05
Flags: needinfo?(echang) → needinfo?(zikui.yang)
See Also: → 1150424
(Reporter)

Comment 14

4 years ago
(In reply to Hermes Cheng[:hermescheng] from comment #13)
> Elie,
> 
> Could you open another bug for this flashing issue? It also affected 2.2.
> 
> (In reply to Elie from comment #10)
> > Verilfied on Flame 3.0. this issue still exist on flame 3.0, but there is
> > some different behavior in new build ---->when I tap the title bar of Select
> > search engine view, the search result view will flash, press home, tap
> > search bar to envoke E.me again ,it will enter Select search engine view
> > directly and the IME pops up unexpectly.
> > Flame 3.0:
> > Build ID               20150401160204
> > Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
> > Gaia Date              2015-04-01 02:06:11
> > Gecko Revision        
> > https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
> > Gecko Version          40.0a1
> > Device Name            flame
> > Firmware(Release)      4.4.2
> > Reproduce rate         5/5
> > Video                  VIDEO0332_Compress.MP4
> > log                    logcat(11).txt
> > Happen time            5:05

This problem exist on flame 3.0 also,I have create a new issue for tracking this problem.
Please refer to:Bug 1150424 https://bugzilla.mozilla.org/show_bug.cgi?id=1150424 
[E.me Integration]After tapping the title bar in search engine selection view,the background page will flash once.
Thanks!
Flags: needinfo?(zikui.yang) → needinfo?(hcheng)
Thanks. Let's track bug 1150424 and keep this bug unverified until bug 1150424 is resolved.
No longer depends on: 1150424
Flags: needinfo?(hcheng)
Issue verified fixed on Flame 3.0

Tapping title bar in search engine selection page from Rocketbar search does not close page and return to home, or flash background.

Issue from bug 1150424 is verified fixed on Flame 3.0

Device: Flame 3.0
Build ID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Issue does not reproduce on Flame 2.2, but issue from bug 1150424 is still affected on Flame 2.2 as patch has not been uplifted. Leaving verifyme keyword awaiting that bug's verification on 2.2 as per comment 15.

Device: Flame 2.2
Build ID: 20150428002500
Gaia: 9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gecko: e79c19bf19bf
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
2.2 has been verified

Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.040203
Firmware Date          Sun May  3 04:02:15 EDT 2015
Bootloader             L1TC000118D0
You need to log in before you can comment on or make changes to this bug.