Closed Bug 1149120 Opened 5 years ago Closed 5 years ago

[Flame][Music]The pause button is displayed in random button above at Albums view.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S10 (17apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: yulan.zhu, Assigned: dkuo)

References

Details

(Keywords: regression)

Attachments

(6 files)

Attached file logcat_0534.txt
[1.Description]:
[Flame][v3.0][Music]The pause button is displayed in random button above at Albums view.
Found time:05:34
See attachment:video and logcat_0534.txt

[2.Testing Steps]: 
1. Have some music in device.
2. Launch Music app.
3. Change to Albums view.
4. Select a Albums.
5. Observe the pause button and random button.

[3.Expected Result]: 
5. Pause button should be shown at left side of random button in the same horizontal line.

[4.Actual Result]: 
5. The pause button is shown in random button above.

[5.Reproduction build]: 
Device: Flame 2.2 (unaffected)
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.035453
Firmware Date          Sun Mar 29 03:55:05 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.042104
Firmware Date          Sun Mar 29 04:21:16 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,6/10

[7.TCID]: 
Free Test

[8.Note]:
I have also uploaded the music which has this problem.
Attached video video.MP4
My patch in bug 1140154 caused this :P
Assignee: nobody → dkuo
blocking-b2g: --- → 2.2?
Keywords: regression
The Artist view has the same problem, test step as follow:
1.Launch Music
2.Switch to Artist view->tap an artist with short name(Such as "黄小琥")
3.Press back ,tap an  artist with long name(Such as "GD X TAEYANG" )
When the artist name is short, the layout of Artist view will change,The artist name is right-aligned, the play icon is in random play button above.Please refer to picture 1.png and 2.png

And this issue can be reproduce on flame 2.2 and 3.0
Reproduce rate:5/5
Test build:
Flame 2.2: affected
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2

Flame 3.0: affected
Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Attached image 1.png
Attached image 2.png
Blocks: 1149449
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8590191 [details] [review]
[gaia] dominickuo:bug-1149120 > mozilla-b2g:master

This should fix the bdi problem.
Attachment #8590191 - Flags: review?(squibblyflabbetydoo)
Attachment #8590191 - Flags: review?(squibblyflabbetydoo) → review+
Duplicate of this bug: 1149449
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8590191 [details] [review]
[gaia] dominickuo:bug-1149120 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1140154.
[User impact] if declined: Bad ux with wrong ui alignment.
[Testing completed]: No tests needed(CSS changes) but verified with human eyes.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8590191 - Flags: approval-gaia-v2.2?
Attachment #8590191 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Blocks: music-rtl
This issue verified successfully on flame 2.2 &3.0
Flame 2.2:  
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flame 3.0: 
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate         0/10
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.