Status

Marketing
Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: lizzn, Assigned: Rainer Cvillink)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

3 years ago
>>Project/Request Title:
WOM Internal Promo Video

>>Project Overview:
Similar to the internal videos for Hello that played at the Monday Meetings, we'd like to do an "internal excitement video" for the Word of Mouth Marketing program and platform, powered by SocialChorus. This video should encourage employees to sign up for the platform. 

Jess and Lizz will be meeting w/ Rainer and Spencer on 03/31 to go over specifics of the video. 

>> Creative Help Needed:
Copy:    No 
Design:  No 
Video:   Yes 
Other:  No

>>Creative Specs:
Video should be 1 - 1:30 mins

>>CTA and Design:
CTA: sign up for the new WOMM program

>>Expected Launch Date:
2015-04-27

>>Mozilla Goal:
Million Mozillians

>>Mozilla Creative Collective:
No

>>Points of Contact:
rcvillink@mozilla.com, shui@mozilla.com, josorio@mozilla.com, matej@mozilla.com, kbaird@mozilla.com, williamr@mozilla.com,
(Reporter)

Updated

3 years ago
Blocks: 1145880
(Reporter)

Updated

3 years ago
Due Date: 2015-04-24

Updated

3 years ago
Assignee: jbalaco → nobody
Component: Design → Video
(Reporter)

Updated

3 years ago
Due Date: 2015-04-24 → 2015-04-17

Updated

3 years ago
Assignee: nobody → rcvillink
Status: NEW → ASSIGNED

Comment 1

3 years ago
Adding video link: https://www.youtube.com/watch?v=vcDJwn7vCCQ

Feedback coming from Jessica.
FROM Spencer, 4/21:
Hey guys,

This is the first of three videos around the word of marketing project.
This first one is for internal audience to be shown at the next Monday meeting.

Firefox Friends - first draft:
https://www.youtube.com/watch?v=vcDJwn7vCCQ


From Matej, 4/21: 
Hey Spencer,

This is looking good, but needs a few tweaks on the supers, both on the “Firefox Friends” lockup and on the copy.

I’m adding Matt, who’s working on the site design, and Troy, who’s working on copy, to this email. They should be able to get you what you need.

Also, is that the final URL? And will that point to the landing page or to the signup form?

Thanks.

From Jess, 4/21:
Hey Hey!

+Kristin +William (please include them in all WoMM comms) :)

I think we lose the message a little after the "how awesome would it be..." when we switch from person to person... I think it may be the differences in volume.

Alex Costello's part needs to be louder or maybe redone... or maybe it's that we broke up that one line and it shouldn't be... "news and updates" would sound better in one line coming from one person... just food for thought here.

I know we're working with placeholders too since the design isn't ready yet but I think we should:

    Have a voice over when we say "Introducing Firefox Friends!" - since it will be the FIRST time Mozillians here/see this new program name...
    We should show the platform... and someone scrolling in it during this part of the video.

Also, the URL for this video should be: friends.mozilla.org - this is the vanity URL that will lead straight to the sign up page on the platform.

Lets also include the program hashtag: #FirefoxFriends

I'm syncing w/ Lizz N today to see when we can expect the design so you guys can incorporate that too.

Thank you!


From Spencer, 4/21:
Most of the text and work mark are all stands ins for now, same goes for the URL. Wanted to show the general wipe of the video as it stands since its due on Monday.

If you guys can send me a link to the site and I can pull copy off from there that would great.



THANKS!

Comment 3

3 years ago
Hey folks

Here are a couple of options for the supers / title screens.

(each line would be its own super)

Supers - option 1
Introducing Firefox Friends
The new social sharing program from Mozilla
Join Firefox Friends and help us spread the word
friends.mozilla.org

Supers - option 2
Introducing Firefox Friends
Share Mozilla news with the world and get rewarded 
Join Firefox Friends and help us spread the word
friends.mozilla.org

Let me know what you think.

Thanks,
Troy
(Assignee)

Comment 4

3 years ago
Troy, thx that was very helpful
(Assignee)

Comment 5

3 years ago
next version

https://youtu.be/Nhs3R-WVH94

Comment 6

3 years ago
Setting a flag for Matt to add graphic elements when they're ready.
Flags: needinfo?(mternoway)

Comment 7

3 years ago
Hi all, here is a link to a zip containing the final Firefox Friends logo. Included in the zip are 3 variations of the logo, for various scenarios. All in .eps format. Let me know if I can provide any other formats.

Firefox Friend logos:
https://www.dropbox.com/s/h860kh2w4s7fdpi/firefox-friends_logo.zip?dl=0

MT
I'm ok with the new order for the supers. 

I still think we need the voice over for the "introducing firefox friends..." 

Can we record this tomorrow in MTV, Rainer? I will be there.

Thank you!
Flags: needinfo?(rcvillink)
(Assignee)

Comment 9

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #8)
> I'm ok with the new order for the supers. 
> 
> I still think we need the voice over for the "introducing firefox
> friends..." 
> 
> Can we record this tomorrow in MTV, Rainer? I will be there.
> 
> Thank you!

sure ... no problem ... I will send a new version with the logo soon ...
Flags: needinfo?(rcvillink)
(Assignee)

Comment 10

3 years ago
.. next draft with new logo, blue BG and VO "introducing firefox friends" 

https://youtu.be/Cx1jIyFhDnM
(In reply to Rainer Cvillink from comment #10)
> .. next draft with new logo, blue BG and VO "introducing firefox friends" 
> 
> https://youtu.be/Cx1jIyFhDnM

Looking good, but I realize we gave you the wrong version of the logo. Matt is going to share the correct one.

It's also looking really red in the video, but it should be more orange. Is that just because of the blue background?

I think Matt is also creating some icons for the site, so you should be able to use those for the three icons towards the end.

Thanks.
Flags: needinfo?(mternoway) → needinfo?(mternoway)

Comment 12

3 years ago
Hi all, sorry for the confusion, but I posted the wrong logo assets here earlier. Here is a link to the proper final ones. I've also Emailed assets directly to Rainer.

https://www.dropbox.com/s/h860kh2w4s7fdpi/firefox-friends_logo.zip?dl=0 

MT
Flags: needinfo?(mternoway)
(Assignee)

Comment 13

3 years ago
here would be RC1 of the video

https://youtu.be/wIhenZAO2hs
I LOVE LOVE LOVE IT! 

I have no more feedback! 

Kristin, William?
Flags: needinfo?(williamr)
Flags: needinfo?(kbaird)
Love it! Spotted a bug at 0:40, where the Firefox logo on the t-shirt is not showing correctly. Everything else looks great :)
Flags: needinfo?(williamr)
(In reply to William Reynolds [:williamr] from comment #15)
> Love it! Spotted a bug at 0:40, where the Firefox logo on the t-shirt is not
> showing correctly. Everything else looks great :)

Good catch!

I agree that it looks awesome, but the Friends logo still looks really red.

Rainer, can you confirm that it's the correct colour?

Thanks.
(Assignee)

Comment 17

3 years ago
(In reply to Matej Novak [:matej] from comment #16)
> (In reply to William Reynolds [:williamr] from comment #15)
> > Love it! Spotted a bug at 0:40, where the Firefox logo on the t-shirt is not
> > showing correctly. Everything else looks great :)

will be fixed in the next version
> 
> Good catch!
> 
> I agree that it looks awesome, but the Friends logo still looks really red.

yeah that is a h.264 color reproduction issue ..... looks good before the upload .... I will try to fix it in the next version  ....
> 
> Rainer, can you confirm that it's the correct colour?
> 
> Thanks.

Comment 18

3 years ago
Love it!
Flags: needinfo?(kbaird)
Hey Rainer! Just following up on the status of that one fix that's missing? 

I'd love to get that and mark this item as resolved so we can move onto the next two videos that need to be worked on this week. 

I'll be in MTV tomorrow so we can work together on those. :)

thank you!
Flags: needinfo?(rcvillink)
(Assignee)

Comment 20

3 years ago
here is the next version of the "Firefox Friends" internal rah rah video .... all bugs should be fixed .... as well as the color of the logo in the front .... pls recheck that .....

https://youtu.be/MOTUoYD3s0c
Flags: needinfo?(rcvillink)
Looks great, Rainer. Just one little thing: Can you remove the period after "rewarded" at :35?

Thanks.
Hey Guys!

After some really important feedback we got from Mary we made edits to the script for the Internal Excitement Video! 

New script here on page 2 and highlighted in yellow: https://docs.google.com/document/d/1goVKQYWCxQaavTLIGkFz3knxP6naWehcyjv9uOjUvpQ/edit#

Matej, can you take a look at it today? Please :)

Rainer/Spencer can we film these edits tomorrow in SF? I'm available after lunch, any time!
Flags: needinfo?(matej)
Already got Matej's feedback thank you, Matej!
Flags: needinfo?(matej)
(Assignee)

Comment 24

3 years ago
> 
> Rainer/Spencer can we film these edits tomorrow in SF? I'm available after
> lunch, any time!

I could be there at around 2pm ....
Hi Team: 

We need more help on the copy, per Mary's 2nd round of feedback.

Troy can you please take a stab at re-working the intro for this Internal Excitement Video too.
We'd like for Troy to be the copywriter that takes a stab at this since he's been working on all the copy for this program.

Please confirm if this is ok and if it's possible and if so, if we could see some revised copy before noon (PT) tomorrow, 5/1 - that would be awesome! 

Copy is being worked here: https://docs.google.com/document/d/1goVKQYWCxQaavTLIGkFz3knxP6naWehcyjv9uOjUvpQ/edit#heading=h.xtr0zw1xnyd

Liz N: Please help us confirm the above as soon as possible.
Flags: needinfo?(enoonan)

Comment 26

3 years ago
Hey Jess

Unless anyone else has plans for me, I can definitely work on this for tomorrow.

Troy

(In reply to Jessica Osorio [:josorio] from comment #25)
> Hi Team: 
> 
> We need more help on the copy, per Mary's 2nd round of feedback.
> 
> Troy can you please take a stab at re-working the intro for this Internal
> Excitement Video too.
> We'd like for Troy to be the copywriter that takes a stab at this since he's
> been working on all the copy for this program.
> 
> Please confirm if this is ok and if it's possible and if so, if we could see
> some revised copy before noon (PT) tomorrow, 5/1 - that would be awesome! 
> 
> Copy is being worked here:
> https://docs.google.com/document/d/
> 1goVKQYWCxQaavTLIGkFz3knxP6naWehcyjv9uOjUvpQ/edit#heading=h.xtr0zw1xnyd
> 
> Liz N: Please help us confirm the above as soon as possible.
(Reporter)

Updated

3 years ago
Flags: needinfo?(enoonan)

Comment 27

3 years ago
New script is in the doc (previous version is still there for reference — the new one is the highlighted copy on page 2.)

https://docs.google.com/document/d/1goVKQYWCxQaavTLIGkFz3knxP6naWehcyjv9uOjUvpQ/edit#heading=h.xtr0zw1xnyd
(Assignee)

Comment 28

3 years ago
Here is the next version of the video with new script

https://youtu.be/W_Rw0gFHrHU

Comment 29

3 years ago
Thanks Rainer. Totally appreciate the quick turn on this.

Few quick thoughts from me. 
- the first super is lost. In fact, I didn't even see it the first time. It comes and goes so fast. The music is great as the lead in but don't think we really get people's attention until Jess start's talking. 
- it sounds to me a tiny bit like Laura is stumbling over the line "our exciting new program...." Is there a different cut of her saying that we can use?

I hate to even say this but I just have to. The energy in this video is as fun, upbeat and engaging as the original video. Is it the script? 

Would love to hear other people's thoughts. 

Thanks again!
(Assignee)

Comment 30

3 years ago
Next draft ... I made the changes ... I think I fixed Lauras stumbling .... and added some stuff .... let me know what you want to keep .... 

https://youtu.be/Vkj8pSklCb0
(In reply to Rainer Cvillink from comment #30)
> Next draft ... I made the changes ... I think I fixed Lauras stumbling ....
> and added some stuff .... let me know what you want to keep .... 
> 
> https://youtu.be/Vkj8pSklCb0

Hey Rainer,

This is looking really good. I love the supers at the end.

My only comment would be to keep the "All the news all in one place" line in audio. It wasn't immediately clear to me that the people asking "All in one place?" was in response to that.

Does that make sense?

Thanks.
(Assignee)

Comment 32

3 years ago
It makes a lot of sense .... and here is new version

https://youtu.be/9sPooUaW8to(In reply to Matej Novak [:matej] from comment #31)
> (In reply to Rainer Cvillink from comment #30)
> > Next draft ... I made the changes ... I think I fixed Lauras stumbling ....
> > and added some stuff .... let me know what you want to keep .... 
> > 
> > https://youtu.be/Vkj8pSklCb0
> 
> Hey Rainer,
> 
> This is looking really good. I love the supers at the end.
> 
> My only comment would be to keep the "All the news all in one place" line in
> audio. It wasn't immediately clear to me that the people asking "All in one
> place?" was in response to that.
> 
> Does that make sense?
> 
> Thanks.

It makes a lot of sense .... and here is new version

https://youtu.be/9sPooUaW8to
Looks awesome. Thanks!

Comment 34

3 years ago
Looks great! Thanks for the hustle on this one! 

We will show it today.
Thanks Team!

Great work!
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.