[Flame][Gallery]Gallery can't be switch to landscape.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: gduan)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Flame][v2.2&3.0][Gallery]Invoke E.me in landscape, enter wifi settings from eme when there is no data connection, then return to Gallery,you will found that Gallery can't be rotate to landscape. 
Attchment:VIDEO0325_clip_Compress.MP4 and logcat_2252.txt
Happen time: 10::52

[2.Testing Steps]: 
1.Disable Wifi or other data network
2.Launch Gallery 
3.Switch to landscape
4.Drag notification and tap search input box->input some key words
>>It is shown no inernet connection.
5.Tap "no inernet connection" to enter wifi settings
6.Tap Done to return to gallery
7.Rotate to landscape

[3.Expected Result]: 
7.The Gallery can‘t be switched to landscape.

[4.Actual Result]: 
7.The Gallery can't be switched to landscape.

[5.Reproduction build]: 
Flame 2.2: Affected
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flame 3.0:  Affected
Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Reporter

Comment 2

4 years ago
Posted file logcat_2252.txt
Reporter

Updated

4 years ago
Hi, Elie,

Can it be reproduced on v2.1?
Thanks.
Flags: needinfo?(zikui.yang)
Reporter

Comment 4

4 years ago
absolete
(In reply to William Hsu [:whsu] from comment #3)
> Hi, Elie,
> 
> Can it be reproduced on v2.1?
> Thanks.

Hi Eric
This issue does not exist on Flame 2.1 
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0
Reproduce rate  0/5
Flags: needinfo?(zikui.yang) → needinfo?(echang)
Reporter

Comment 5

4 years ago
(In reply to William Hsu [:whsu] from comment #3)
> Hi, Elie,
> 
> Can it be reproduced on v2.1?
> Thanks.

Hi William
This issue does not exist on Flame 2.1 
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0
Reproduce rate  0/5
Reporter

Updated

4 years ago
Flags: needinfo?(echang) → needinfo?
Reporter

Updated

4 years ago
Flags: needinfo? → needinfo?(whsu)
Defect only happens on v2.2.
Inconsistent behavior between release. Please make a decision to see if we can fix it on v2.2.

Thanks.
blocking-b2g: --- → 2.2?
Flags: needinfo?(whsu)

Comment 7

4 years ago
Blocking Reason: regression and it looks like a similar issue that we saw in the camera case too. No-jun is looking for that bug and possibly linking it here if it is the same issue.
blocking-b2g: 2.2? → 2.2+
Keywords: regression

Comment 8

4 years ago
Probably not a gallery issue. From the video it looks like the orientation is locked in portrait after step 5 in the settings screen. David, can you confirm and route accordingly.

Thanks
Hema
Flags: needinfo?(dflanagan)
I can reproduce this. It is almost certainly a window management bug.
Component: Gaia::Gallery → Gaia::System::Window Mgmt
Flags: needinfo?(dflanagan) → needinfo?(alive)
Reverse regression window wanted - what patch in master fix it?
Flags: needinfo?(alive)
Could you help to check if there is a reverse regression window found? Thanks.
Flags: needinfo?(gduan)
Assignee: nobody → gduan
Flags: needinfo?(gduan)
This issue DOES reproduce on Flame 3.0. I'll work on getting a regular regression window (not reverse).

Environmental Variables:
Device: Flame 3.0
BuildID: 20150409085330
Gaia: eaf69e651e19b98c096f8e63b9829fb31df50927
Gecko: dd32e3ff3717
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
This issue DOES reproduce on Flame 3.0. I'll work on getting a regular regression window (not reverse).

Environmental Variables:
Device: Flame 3.0
BuildID: 20150409085330
Gaia: eaf69e651e19b98c096f8e63b9829fb31df50927
Gecko: dd32e3ff3717
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141020205719
Gaia: e09e1734ad523cf63351a28f6f84454319349fbe
Gecko: 4da1f6a151d6
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141020214218
Gaia: ba10744d64411a8a12ae68f7cf1ec3e3ac897d21
Gecko: bcc5df613d83
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue ___ reproduce 
Gaia: e09e1734ad523cf63351a28f6f84454319349fbe
Gecko: bcc5df613d83

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: ba10744d64411a8a12ae68f7cf1ec3e3ac897d21
Gecko: 4da1f6a151d6

https://github.com/mozilla-b2g/gaia/compare/e09e1734ad523cf63351a28f6f84454319349fbe...ba10744d64411a8a12ae68f7cf1ec3e3ac897d21

Caused by bug 1007600
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Arthur, can you take a look at this please? This looks to have been caused by the landing for bug 1007600.
Blocks: 1007600
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(arthur.chen)
A critical step in the STR is invoking settings app using inline disposition. Before bug 1007600 landed settings app was opened using window disposition. Alive, any idea why the difference leads to the issue?
Flags: needinfo?(arthur.chen) → needinfo?(alive)
Comment on attachment 8591557 [details] [review]
[gaia] cctuan:1149446 > mozilla-b2g:master

Hi Alive,
This patch should fix this pb and not affect the fix of bug 1063740.
I've tried serveral cases, such as portrait/default app call activityWindow and call searchWindow and call settings.
Attachment #8591557 - Flags: review?(alive)
Comment on attachment 8591557 [details] [review]
[gaia] cctuan:1149446 > mozilla-b2g:master

Thanks
Flags: needinfo?(alive)
Attachment #8591557 - Flags: review?(alive) → review+
Thanks,
https://github.com/mozilla-b2g/gaia/commit/131ddf113aacb6582e30348b92e3c6211110a7e3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8591557 [details] [review]
[gaia] cctuan:1149446 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a feature nor a regression.
[User impact] if declined: Gallery app cannot rotate after steps from comment 0, see attachment 8585974 [details].
[Testing completed]: Yes, unit test and manual test.
[Risk to taking this patch] (and alternatives if risky): I've tested most of app switching cases, but I haven't found any failing case.
[String changes made]:
Attachment #8591557 - Flags: approval-gaia-v2.2?
Attachment #8591557 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 23

4 years ago
This issue verified successfully on flame 2.2&3.0:
Flame 2.2: 
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Flame 3.0:
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate         0/10
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.