Closed Bug 1149497 Opened 5 years ago Closed 4 years ago

Wildcard domain (*.domain.com) cookies are not displayed

Categories

(DevTools :: Storage Inspector, defect)

40 Branch
x86
macOS
defect
Not set

Tracking

(firefox48 fixed)

RESOLVED FIXED
Firefox 48
Tracking Status
firefox48 --- fixed

People

(Reporter: m+bugzilla, Assigned: jsnajdr)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150330114816

Steps to reproduce:

- Create a cookie with ".domain.com" (do not forget the ".")
- Go to domain.com (without any subdomain)


Actual results:

You won't see the cookie in devtools > storage > cookie > domain.com


Expected results:

You should see the cookie in devtools > storage > cookie > domain.com
Component: Untriaged → Developer Tools: Storage Inspector
Depends on: 1194190
Blocks: 1194190
No longer depends on: 1194190
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Wildcard cookies are not listed in the main domain → Wildcard domain (*.domain.com) cookies are not displayed
Duplicate of this bug: 1254048
Fixed the code that checks if a cookie domain matches a host - ".example.org" now matches "example.org".
Attachment #8741324 - Flags: review?(mratcliffe)
Assignee: nobody → jsnajdr
Attachment #8741324 - Flags: review?(mratcliffe) → review+
Keywords: checkin-needed
has problems to apply:

applying Bug-1149497---Wildcard-domain-cookies-are-not-disp.patch
patching file devtools/client/storage/test/browser.ini
Hunk #1 FAILED at 14
1 out of 1 hunks FAILED -- saving rejects to file devtools/client/storage/test/browser.ini.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh Bug-1149497---Wildcard-domain-cookies-are-not-disp.patch
Flags: needinfo?(jsnajdr)
Keywords: checkin-needed
Rebased on the latest m-c.
Attachment #8743671 - Flags: review+
Attachment #8741324 - Attachment is obsolete: true
Flags: needinfo?(jsnajdr)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2ca0a1672d8f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.