Treeherder should provide a REST api to obtain bug suggestions

RESOLVED DUPLICATE of bug 1080760

Status

Tree Management
Treeherder: API
--
enhancement
RESOLVED DUPLICATE of bug 1080760
3 years ago
3 years ago

People

(Reporter: bc, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
In https://github.com/mozilla/treeherder-service/blob/master/treeherder/log_parser/utils.py the function extract_text_log_artifacts creates the bug_suggestions artifact which is used internally by Treeherder to populate the suggested bugs for buildbot initiated tests from the test log.

Non-buildbot test frameworks would benefit greatly if Treeherder were to expose an http api where the user could provide the text of an error line and get back the bug_suggestions artifact.

Comment 1

3 years ago
This was fixed in bug 1080760, but with the approach that non-buildbot submitters provide the error excerpt, and Treeherder then adds the bug suggestions.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1080760
You need to log in before you can comment on or make changes to this bug.