before pseudo class float:right doesn't reflow properly

RESOLVED DUPLICATE of bug 944200

Status

()

RESOLVED DUPLICATE of bug 944200
4 years ago
4 years ago

People

(Reporter: therealpaulgrant, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36

Steps to reproduce:

HTML: 
<div class="box">
  <div class="content">
   This is some content that gets overlapped in Firefox
  </div>
</div>

CSS: 
.box {
  width:340px;
  background:#333;
  color:#FFF;
  padding:50px
}

.content {
  overflow:hidden;
  white-space:nowrap;
  text-overflow:ellipsis;
}

.content:before {
  content:"overlap";
  float:right;
}


Actual results:

The float:right overlaps the content. float:left works as expected.


Expected results:

should cause content to reflow.

http://codepen.io/anon/pen/bNJdvY

Updated

4 years ago
Component: Untriaged → Layout: Floats
Product: Firefox → Core
The content is not allowed to wrap, so it can't wrap to avoid the float.  What exactly did you expect the layout to look like in this case?

Note that Chrome has a known bug with respect to the spec here: it ellipsizes text that does not actually overflow the box.  See the discussion in bug 944200.  Is this a duplicate of that one?
Flags: needinfo?(therealpaulgrant)
Ah, yes, it is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(therealpaulgrant)
Resolution: --- → DUPLICATE
Duplicate of bug: 944200
You need to log in before you can comment on or make changes to this bug.