Closed Bug 1149808 Opened 5 years ago Closed 7 months ago

WebGL rendering error background texture is blank

Categories

(Core :: Canvas: WebGL, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: drewjpotter, Assigned: jgilbert)

References

Details

(Whiteboard: gfx-noted)

Attachments

(1 file)

Attached image solar_system.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/600.3.18 (KHTML, like Gecko) Version/8.0.3 Safari/600.3.18

Steps to reproduce:

Visit: https://www.blend4web.com/apps/webplayer/webplayer.html?load=../../assets/interactivity/solar_system/solar_system_en.json&v=20150326165850

The background galaxy texture is omitted. This is just for Firefox (and also Nightly build) for OS X with Intel graphics card.

The problem is the background texture does not load.

I am using Firefox version: 36.0.4
I am using OS X version: 10.10.2


Actual results:

The background image does not load.


Expected results:

There should have been a background image.
Some conversation on the topic in bug 986871
See Also: → 986871
Note; this affects Intel graphics cards on OS X.
Component: Untriaged → Graphics
Product: Firefox → Core
Version: 36 Branch → unspecified
Component: Graphics → Canvas: WebGL
Whiteboard: gfx-noted
Note; this bug does not happen using Safari or Chrome.
This is the bug you mentioned yesterday, right Jeff?
Flags: needinfo?(jgilbert)
Seems to be working in Nightly46
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → FIXED
Seems to be broken again!
Using :
- FF 47.0.1 (also true with latest Nightly version)
- Mac OS 10.11.5
- MBP 12.1
- Intel Iris Graphics 6100

This page: https://www.browserleaks.com/webgl gives me only 512 for the "Max Cube Map Texture Size" property and I cannot play this panorama: https://pannellum.org/documentation/examples/cube-map/

For the record, Chrome and Safari give me 16384 for the "Max Cube Map Texture Size" property.
We've had, and still have, a 512 limit on the cube maps on Intel.  So, if this bug is to remove that limitation, then it's not resolved fixed.
There are no limits for cube map on other vendors.

Arthur, to test if we're talking about the same thing - set gfx.work-around-graphics-bugs to false (in about:config) and restart Firefox.  You shouldn't have the 512 limit at that point.  Can you confirm?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
(In reply to Milan Sreckovic [:milan] from comment #7)
> We've had, and still have, a 512 limit on the cube maps on Intel.  So, if
> this bug is to remove that limitation, then it's not resolved fixed.
> There are no limits for cube map on other vendors.
> 
> Arthur, to test if we're talking about the same thing - set
> gfx.work-around-graphics-bugs to false (in about:config) and restart
> Firefox.  You shouldn't have the 512 limit at that point.  Can you confirm?

I think we're definitely talking about the same thing: 512 limit on cube maps size.
However, setting the variable and restarting Firefox didn't fix it.
Assignee: nobody → jgilbert

Let me know if this is still a problem, but it works for me!

Status: REOPENED → RESOLVED
Closed: 4 years ago7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.