Closed Bug 1149842 Opened 6 years ago Closed 6 years ago

Intermittent test_mediarecorder_record_getdata_afterstart.html | application timed out after 330 seconds with no output

Categories

(Core :: Audio/Video: Recording, defect)

39 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla41
Tracking Status
firefox38.0.5 --- fixed
firefox39 --- fixed
firefox40 --- fixed
firefox41 --- fixed
firefox-esr31 --- unaffected
firefox-esr38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: KWierso, Assigned: bechen)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

14:49:16 INFO - mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/684edcca-1ec0-8639-13350481-5e13e622.extra
14:49:16 WARNING - PROCESS-CRASH | dom/media/test/test_mediarecorder_record_getdata_afterstart.html | application crashed [@ linux-gate.so + 0x424]
14:49:16 INFO - Crash dump filename: /tmp/tmpW06gqm.mozrunner/minidumps/684edcca-1ec0-8639-13350481-5e13e622.dmp
14:49:16 INFO - Operating system: Linux
14:49:16 INFO - 0.0.0 Linux 3.2.0-76-generic-pae #111-Ubuntu SMP Tue Jan 13 22:34:29 UTC 2015 i686
14:49:16 INFO - CPU: x86
14:49:16 INFO - GenuineIntel family 6 model 45 stepping 7
14:49:16 INFO - 1 CPU
14:49:16 INFO - Crash reason: SIGABRT
14:49:16 INFO - Crash address: 0x70c
14:49:16 INFO - Thread 0 (crashed)
14:49:16 INFO - 0 linux-gate.so + 0x424
14:49:16 INFO - eip = 0xb77a9424 esp = 0xbfd44990 ebp = 0xbfd44a08 ebx = 0x9d0f19a0
14:49:16 INFO - esi = 0x00000000 edi = 0xb7635ff4 eax = 0xfffffffc ecx = 0x00000006
14:49:16 INFO - edx = 0xffffffff efl = 0x00200282
14:49:16 INFO - Found by: given as instruction pointer in context
14:49:16 INFO - 1 libglib-2.0.so.0.3200.1 + 0x4706d
14:49:16 INFO - eip = 0xb1d6e06e esp = 0xbfd44a10 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: previous frame's frame pointer
14:49:16 INFO - 2 libglib-2.0.so.0.3200.1 + 0xf88ff
14:49:16 INFO - eip = 0xb1e1f900 esp = 0xbfd44a28 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 3 libglib-2.0.so.0.3200.1 + 0x863cf
14:49:16 INFO - eip = 0xb1dad3d0 esp = 0xbfd44a30 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 4 libglib-2.0.so.0.3200.1 + 0x868f5
14:49:16 INFO - eip = 0xb1dad8f6 esp = 0xbfd44a38 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 5 libxul.so!nsAppShell::ScheduleNativeEventCallback() [nsAppShell.cpp:8dd6520e5a55 : 151 + 0x4]
14:49:16 INFO - eip = 0xb3b075d3 esp = 0xbfd44a40 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 6 libglib-2.0.so.0.3200.1 + 0xf8593
14:49:16 INFO - eip = 0xb1e1f594 esp = 0xbfd44a44 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 7 libnspr4.so!_fini + 0x113b7
14:49:16 INFO - eip = 0xb7489550 esp = 0xbfd44a58 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 8 libglib-2.0.so.0.3200.1 + 0x46efa
14:49:16 INFO - eip = 0xb1d6defb esp = 0xbfd44a5c ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 9 libglib-2.0.so.0.3200.1 + 0xf7ff3
14:49:16 INFO - eip = 0xb1e1eff4 esp = 0xbfd44a60 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 10 libglib-2.0.so.0.3200.1 + 0x471c0
14:49:16 INFO - eip = 0xb1d6e1c1 esp = 0xbfd44a70 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 11 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44a80 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 12 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44a84 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 13 libxul.so!nsAppShell::ProcessNextNativeEvent(bool) [nsAppShell.cpp:8dd6520e5a55 : 156 + 0xb]
14:49:16 INFO - eip = 0xb3b073b2 esp = 0xbfd44a90 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 14 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44aa4 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 15 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44aa8 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 16 libxul.so!nsBaseAppShell::DoProcessNextNativeEvent(bool, unsigned int) [nsBaseAppShell.cpp:8dd6520e5a55 : 140 + 0xc]
14:49:16 INFO - eip = 0xb3ae1132 esp = 0xbfd44ab0 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 17 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44abc ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 18 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44ac0 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 19 libxul.so!nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, bool, unsigned int) [nsBaseAppShell.cpp:8dd6520e5a55 : 298 + 0xe]
14:49:16 INFO - eip = 0xb3ae124f esp = 0xbfd44ae0 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 20 libxul.so!nsXPConnect::OnProcessNextEvent(nsIThreadInternal*, bool, unsigned int) [nsXPConnect.cpp:8dd6520e5a55 : 938 + 0xa]
14:49:16 INFO - eip = 0xb2a195cd esp = 0xbfd44b0c ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 21 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44b10 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 22 libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:8dd6520e5a55 : 819 + 0x1d]
14:49:16 INFO - eip = 0xb24a298c esp = 0xbfd44b20 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 23 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44b34 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 24 libxul.so!_fini + 0x1ef13ef
14:49:16 INFO - eip = 0xb6dcd1c8 esp = 0xbfd44b38 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 25 libnspr4.so!PR_Unlock [ptsynch.c:8dd6520e5a55 : 194 + 0xa]
14:49:16 INFO - eip = 0xb7469f2b esp = 0xbfd44b3c ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 26 libxul.so!mozilla::OffTheBooksMutex::Unlock() [BlockingResourceBase.cpp:8dd6520e5a55 : 390 + 0x8]
14:49:16 INFO - eip = 0xb24b9c65 esp = 0xbfd44b50 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 27 libxul.so!mozilla::OffTheBooksMutex::Unlock() [BlockingResourceBase.cpp:8dd6520e5a55 : 388 + 0xc]
14:49:16 INFO - eip = 0xb24b9c4d esp = 0xbfd44b60 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 28 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44b64 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 29 libxul.so!TimerThread::RemoveTimer(nsTimerImpl*) [TimerThread.cpp:8dd6520e5a55 : 438 + 0xb]
14:49:16 INFO - eip = 0xb24a56c2 esp = 0xbfd44b70 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 30 libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:8dd6520e5a55 : 743 + 0xa]
14:49:16 INFO - eip = 0xb24a2695 esp = 0xbfd44b7c ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 31 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44b80 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 32 libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:8dd6520e5a55 : 265 + 0xf]
14:49:16 INFO - eip = 0xb24c30fb esp = 0xbfd44b90 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 33 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44bc8 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 34 libxul.so!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [MessagePump.cpp:8dd6520e5a55 : 140 + 0xb]
14:49:16 INFO - eip = 0xb274042e esp = 0xbfd44bd0 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 35 libpthread-2.15.so + 0xb87e
14:49:16 INFO - eip = 0xb778387f esp = 0xbfd44be4 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 36 libxul.so!_fini + 0x1d8d41f
14:49:16 INFO - eip = 0xb6c691f8 esp = 0xbfd44bf4 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 37 libxul.so!_fini + 0x1f793bb
14:49:16 INFO - eip = 0xb6e55194 esp = 0xbfd44bf8 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 38 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44c04 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 39 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44c08 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 40 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44c10 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 41 libxul.so!MessageLoop::RunInternal() [message_loop.cc:8dd6520e5a55 : 233 + 0x13]
14:49:16 INFO - eip = 0xb27206ba esp = 0xbfd44c20 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 42 libxul.so!MessageLoop::RunInternal() [message_loop.cc:8dd6520e5a55 : 232 + 0x4]
14:49:16 INFO - eip = 0xb2720675 esp = 0xbfd44c30 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 43 libxul.so!MessageLoop::RunInternal() [message_loop.cc:8dd6520e5a55 : 231 + 0x9]
14:49:16 INFO - eip = 0xb2720664 esp = 0xbfd44c40 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 44 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44c44 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 45 libxul.so!MessageLoop::Run() [message_loop.cc:8dd6520e5a55 : 226 + 0x7]
14:49:16 INFO - eip = 0xb27206e0 esp = 0xbfd44c50 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 46 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44c60 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 47 libxul.so!_fini + 0x1f66e27
14:49:16 INFO - eip = 0xb6e42c00 esp = 0xbfd44c68 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 48 libxul.so!nsBaseAppShell::Run() [nsBaseAppShell.cpp:8dd6520e5a55 : 164 + 0xd]
14:49:16 INFO - eip = 0xb3ad5de1 esp = 0xbfd44c80 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 49 libxul.so!nsBaseAppShell::Run() [nsBaseAppShell.cpp:8dd6520e5a55 : 164 + 0x4]
14:49:16 INFO - eip = 0xb3ad5dd8 esp = 0xbfd44c90 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 50 libnspr4.so!PR_Unlock [ptsynch.c:8dd6520e5a55 : 194 + 0xa]
14:49:16 INFO - eip = 0xb7469f2b esp = 0xbfd44c9c ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 51 libxul.so!_fini + 0x1f66f0f
14:49:16 INFO - eip = 0xb6e42ce8 esp = 0xbfd44ca0 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 52 libxul.so!nsAppStartup::Run() [nsAppStartup.cpp:8dd6520e5a55 : 281 + 0x8]
14:49:16 INFO - eip = 0xb4202b9a esp = 0xbfd44cb0 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - 53 libxul.so!EnumValidate [nsCommandLine.cpp:8dd6520e5a55 : 588 + 0x1]
14:49:16 INFO - eip = 0xb418644e esp = 0xbfd44cb8 ebp = 0x9d0f19a0
14:49:16 INFO - Found by: stack scanning
14:49:16 INFO - Thread 1
Looks like the testcase call MR.requestData() then waiting for ondataavailable.
Assignee: nobody → bechen
Found root cause:
There is deadlock between EncodedBufferCache::ExtractBlob and EncodedBufferCache::AppendBuffer.
ExtractBlob() runs on mainthread and AppendBuffer() runs on others thread.
But there is a sync dispatch NS_OpenAnonymousTemporaryFile in AppendBuffer() cause the deadlock.
Attached patch bug-1149842.v01.patch (obsolete) — Splinter Review
Attachment #8603167 - Flags: review?(roc)
Blocks: 1071375
Keywords: checkin-needed
Wasn't at fault. Will re-land.
https://hg.mozilla.org/mozilla-central/rev/da253a87bcf6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Looks like this affects at least 39+. Does it affect older Gecko versions as well?
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #31)
> Looks like this affects at least 39+. Does it affect older Gecko versions as
> well?

Unfortunately, it affects all versions of gecko because the deadlock exists from the beginning of the file.
And I think the patch can clean apply to other version of gecko.
Flags: needinfo?(bechen)
In that case, please nominate for aurora/beta/esr38/b2g37 :)
Flags: needinfo?(bechen)
Comment on attachment 8603987 [details] [diff] [review]
bug-1149842.v01.patch

Approval Request Comment
[Feature/regressing bug #]: 803414
[User impact if declined]: Deadlock while using MediaRecoder api, testcase fail
[Describe test coverage new/current, TreeHerder]: current, test_mediarecorder_record_*
[Risks and why]: Risk low
[String/UUID change made/needed]: none
Flags: needinfo?(bechen)
Attachment #8603987 - Flags: approval-mozilla-beta?
Attachment #8603987 - Flags: approval-mozilla-aurora?
Comment on attachment 8603987 [details] [diff] [review]
bug-1149842.v01.patch

[Approval Request Comment] ESR38
User impact if declined: Deadlock while using MediaRecoder api, testcase fail
Fix Landed on Version: status-firefox41 (not sure?)
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none


[Approval Request Comment] b2g37
Bug caused by (feature/regressing bug #): 803414
User impact if declined: Deadlock while using MediaRecoder api, testcase fail
Testing completed: central
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #8603987 - Flags: approval-mozilla-esr38?
Attachment #8603987 - Flags: approval-mozilla-b2g37?
Attachment #8603987 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Comment on attachment 8603987 [details] [diff] [review]
bug-1149842.v01.patch

[Triage Comment]
+ release to have it in 38.0.5
Attachment #8603987 - Flags: approval-mozilla-release+
Attachment #8603987 - Flags: approval-mozilla-esr38?
Attachment #8603987 - Flags: approval-mozilla-esr38+
Attachment #8603987 - Flags: approval-mozilla-beta?
Attachment #8603987 - Flags: approval-mozilla-beta+
Attachment #8603987 - Flags: approval-mozilla-aurora?
Attachment #8603987 - Flags: approval-mozilla-aurora+
Flags: qe-verify-
Depends on: 1197669
You need to log in before you can comment on or make changes to this bug.