[CB] Unable to receive CDMA cellbroadcast message

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: steveck, Assigned: steveck)

Tracking

unspecified
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

Should be a regression in Bug #1091751 that the patch for duplicated CMAS message might cause the CDMA CB borken because the logic is only for GSM. We should also check CDMA specific property to resume CDMA CB.

Hi Carol, this issue was reported by Anshul in Bug 1091751 comment 16. Could you please help verify it again that this issue still existed on 2.2 and master? We might not have resource to move CB message handling to Network Alerts app yet, but I think we should fix the CDMA CB message in system first.
Flags: needinfo?(cyang)
(In reply to Steve Chung [:steveck](OOO until 4/6) from comment #0)
> Should be a regression in Bug #1091751 that the patch for duplicated CMAS
> message might cause the CDMA CB borken because the logic is only for GSM. We
> should also check CDMA specific property to resume CDMA CB.
> 
> Hi Carol, this issue was reported by Anshul in Bug 1091751 comment 16. Could
> you please help verify it again that this issue still existed on 2.2 and
> master? We might not have resource to move CB message handling to Network
> Alerts app yet, but I think we should fix the CDMA CB message in system
> first.

Hi Steve,

I'm assuming you're asking me to verify if CDMA CMAS messages will be displayed? If so, yes it does work as the message will not be handled due to [1] but handled at [2].

[1] https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/network-alerts/js/index.js#L47
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/cell_broadcast_system.js#L68
Flags: needinfo?(cyang)
blocking-b2g: 2.2? → 2.2+
(In reply to Carol Yang [:cyang] from comment #1)
> 
> Hi Steve,
> 
> I'm assuming you're asking me to verify if CDMA CMAS messages will be
> displayed? If so, yes it does work as the message will not be handled due to
> [1] but handled at [2].
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/network-alerts/js/index.
> js#L47
> [2]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/
> cell_broadcast_system.js#L68

I don't think all the CDMA related alert message will work because the message id property might not exist in CDMA alert, so this id checking logic should be busted in both network-alerts and cell-broadcast-system. We may still need the fixing in bug 1091751 #c39 in master/2.2 to resume CDMA alert message first.
Per comment 1, since Carol confirmed the CDMA cellbroadcast/CMAS is displayed in 2.2/master (no matter system or network-alerts will handle it), I will close this issue first and handle CDMA CMAS in network-alerts in Bug 1113466.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.