Negative z-index value causes blank DIV display

RESOLVED DUPLICATE of bug 78087

Status

()

--
major
RESOLVED DUPLICATE of bug 78087
17 years ago
17 years ago

People

(Reporter: momoi, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
** Observed with 2001-12-11 Win32 trunk build **

The above page has 2 DIV's on the page (id=Layer1" and id="Layer2").
For styling, it uses z-index values of -2 and -1. These nagative
values seem to cause a display problem with current build resulting in
non-display of these DIV sectinons. 
CSS2 specs simply say that z-index can take "Integer" values. And
"Integer" can have "+" or "-" prefixes, i.e. it can be negative or
possitive.  This seems to be a bug in Mozilla. 

I'll attach 2 test pages below.
(Reporter)

Comment 1

17 years ago
Neither Comm 4.x nor IE5.5 has this problem.
(Reporter)

Comment 2

17 years ago
Created attachment 61554 [details]
The page at above URL with z-index values corrected to 0 and 1 from -2 and -1.

You can see the left and right sections of the page with the corrections 
of the 2 z-index values to positive integers keeping the relative 
positioning intact.
(Reporter)

Comment 3

17 years ago
Created attachment 61555 [details]
The original problem page. Uploaded here in case the original page becomes unavailable.

Look at the z-index values of the original page for the 2 DIVs. -2 and -1.
(Reporter)

Comment 4

17 years ago
Corrected the summary line.
Summary: Negative z-index values causes almost blank display → Negative z-index value causes blank DIV display

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 78087 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.