[Search] Opening filled Rocketbar while returning to home will overlay homescreen with results

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: kgrandon)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
When the user has a search field input in rocketbar, while in another app, opening the 'Search' bar while returning to home via home button (even while at home) will leave the search results overlaying the homescreen.


Repro Steps:
1) Update a Flame to 20150401010204
2) Open 'Search' bar
3) Type 'jumanji' (or anything)
4) Observe results, tap home to maintain search bar field
5) Open the 'Settings' app (or stay at homescreen)
6) Tap 'Search' bar to open and immediately tap home button

Actual:
Phone will navigate to home with search results overlaying homescreen

Expected:
Phone will return to home and dismiss search results


Environmental Variables:
--------------------------------------------------

Device: Flame 3.0
Build ID: 20150401010204
Gaia: 03164bd160809747e6a198e0dba1b7c3ee7789f5
Gecko: 18a8ea7c2c62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150401002624
Gaia: 8b3086ad3963f1707e2bee9094baccafffe161c4
Gecko: 20b67213a047
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150401001203
Gaia: 63c89e001010a9a43ea55afd39333ded3d5e83fc
Gecko: 30ac9a03343a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------------------------------------------------
Issue DOES NOT REPRO on 2.0 for flame devices:
Results: Search bar cannot be opened from other apps, only from top of homescreen. Offers different screen priority that seems to avoid causing overlay.

Device: Flame 2.0
BuildID: 20150401000204
Gaia: 896803174633fc6acd3fd105f81c349b8e9b9633
Gecko: 9c12f28cc73f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
--------------------------------------------------


Repro frequency: 4/5 [mainly timing related]
See attached: 
video- https://youtu.be/tenmyZ7d2dM
logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
(Assignee)

Comment 1

4 years ago
I'll take a look at this.

This also seems fairly bad as you can get pretty stuck, and have a terrible UX. Recommend blocking.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.2?
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
(Assignee)

Comment 2

4 years ago
We had a similar fix in bug 1132262 which we could also use here I think.
See Also: → 1132262
blocking-b2g: 2.2? → 2.2+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8586961 [details] [review]
[gaia] KevinGrandon:bug_1150143_guard_against_early_closing > mozilla-b2g:master

Alberto - since you helped me review bug 1132262, could you help me with this review as well? Thanks!
Attachment #8586961 - Flags: review?(apastor)
Comment on attachment 8586961 [details] [review]
[gaia] KevinGrandon:bug_1150143_guard_against_early_closing > mozilla-b2g:master

Not sure if I can r+ this, as I'm not a peer, but LGTM, thanks!
Attachment #8586961 - Flags: review?(apastor) → review+
(Assignee)

Comment 6

4 years ago
(In reply to Alberto Pastor [:albertopq] from comment #5)
> Not sure if I can r+ this, as I'm not a peer, but LGTM, thanks!

It's ok because the request is coming from a peer and you've done some rocketbar stuff in the past. Thank you for the review :)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
Please nominate this patch for Gaia v2.2 approval when you get a chance.
Flags: needinfo?(kgrandon)
(Assignee)

Comment 9

4 years ago
Comment on attachment 8586961 [details] [review]
[gaia] KevinGrandon:bug_1150143_guard_against_early_closing > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Likely there since feature implementation, but a pretty severe bug.
[User impact] if declined: Poor UX with rocketbar.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, fairly self-contained to rocketbar.
[String changes made]: None.
Flags: needinfo?(kgrandon)
Attachment #8586961 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8586961 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: The search result does not overlay homescreen.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150408010203
Gaia: 84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gecko: 078128c2600a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150408002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 43041c78052b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.