Closed Bug 1150225 Opened 5 years ago Closed 5 years ago

Mouse cursor sticks to resizing appearance from sidebar when over web page.

Categories

(Toolkit :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1018639

People

(Reporter: designakt, Unassigned)

Details

Attachments

(2 files)

When moving the cursor over the sidebar and back to Reader View, it previous appearance stay until hoovering text. So the Hand- or Resize-cursor stay even when on buttons in the Reader View toolbar. (see video)
It also happens with the Bookmark toolbar, and a non-Reading-Mode page, as shown in https://dl.dropboxusercontent.com/u/2301433/Firefox/ResizePersistence.mov so I'm going to claim that this is a Toolkit bug, not a Firefox or Reader Mode bug.  :)
Component: Reading List → General
Product: Firefox → Toolkit
Summary: Mouse cursor sticks to previous appearance from sidebar when over Reader View → Mouse cursor sticks to resizing appearance from sidebar when over web page.
Version: 38 Branch → unspecified
http://mxr.mozilla.org/mozilla-central/source/widget/PuppetWidget.cpp
>PuppetWidget::SetCursor(nsCursor aCursor)
>{
>  if (mCursor == aCursor && !mUpdateCursor) {
>    return NS_OK;
>  }

mCursor in PuppetWidget is different from mCursor in nsWindow.
nsWindow(main-window or top-level-window?) has mCursor and PuppetWidget(browser-pane) has its own mCursor too.(it is bad managed state-holder, imo) PuppetWidget doesn't know changes in nsWindow.
Attached patch patchSplinter Review
ClearCachedWidgetCursor is called earlier.
This issue seems to be resolved with Bug 1018639 - [e10s] Mouse cursor indicates a bidirectional resize.
I agree, and have verified that it works in the latest nightly in both e10s and non-e10s mode.
Resolving as a dupe.  Thanks!  :)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018639
You need to log in before you can comment on or make changes to this bug.