[MTBF][Nexus5-L] Nexus 5 has been shut down after running MTBF for a while

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ashiue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Reporter)

Description

4 years ago
2 devices encountered shutdown problem when running MTBF a while. (28 hours and 13 hours for each device)

and We found lots of cpu bring up error message in dmesg:
<4>[104667.874711] _cpu_up: attempt to bring up CPU 3 failed
<4>[104667.923323] _cpu_up: attempt to bring up CPU 1 failed
<4>[104667.924029] _cpu_up: attempt to bring up CPU 2 failed
<4>[104667.924695] _cpu_up: attempt to bring up CPU 3 failed ...

please refer the whole log information: https://drive.google.com/a/mozilla.com/folderview?id=0B_lQ-lNDWe2oVWZlUzYyYmRKXzQ&usp=sharing


Version info:
Gaia-Rev        cc11248ab69f13e89416c8e6bb2e184187e72088
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Build-ID        20150330162503
Version         37.0
Device-Name     hammerhead
FW-Release      5.0
FW-Incremental  eng.cltbld.20150330.201653
FW-Date         Mon Mar 30 20:17:07 EDT 2015
Bootloader      HHZ12d
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=MTBF-Nexus5L]
(Reporter)

Comment 1

4 years ago
This issue would block MTBF testing on Nexus 5 L, nominate to 2.2.
Hi Viral, any idea for this problem?
blocking-b2g: --- → 2.2?
Flags: needinfo?(vwang)
the error log looks like cpu met some error and can't bring up.
It's a kernel issue should be less relative to b2g.

We get kernel source code from CAF and did not modify any cpu part in our side.
If changing kernel in MTBF is acceptable, we can provide local build to see if we can avoid this kind of issue.
Flags: needinfo?(vwang)

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
(Reporter)

Updated

4 years ago
Blocks: MTBF-B2G

Comment 3

4 years ago
ni? Michael to let him aware of this issue.
Flags: needinfo?(mvines)
Thanks for the ni.  We have not seen this issue in our builds, our gonk and below is different from hammerhead.
Flags: needinfo?(mvines)
(Reporter)

Comment 5

4 years ago
Until now, we have executed MTBF with Nexus-5-L-5.1 9 times, did not hit this shutsown issue.

Comment 6

4 years ago
mark unconfirmed by comment 4 and comment 5. Please reopen if issue appears again.
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 7

4 years ago
Hi! Alison,

Just want to check that do you see this issue again in past three days?
Thanks

--
Keven
Flags: needinfo?(ashiue)
(Reporter)

Comment 8

4 years ago
(In reply to Keven Kuo [:kkuo] from comment #7)
> Hi! Alison,
> 
> Just want to check that do you see this issue again in past three days?
> Thanks
> 
> --
> Keven

No, I did not see this issue again in past three days.
Flags: needinfo?(ashiue)
(In reply to Alison Shiue from comment #8)
> (In reply to Keven Kuo [:kkuo] from comment #7)
> > Hi! Alison,
> > 
> > Just want to check that do you see this issue again in past three days?
> > Thanks
> > 
> > --
> > Keven
> 
> No, I did not see this issue again in past three days.

marking it resolved wfm then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.