Closed Bug 1150420 Opened 5 years ago Closed 5 years ago

[Callscreen] Call duration stops incrementing if the phone falls into sleep mode

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: liuyong, Assigned: thills)

References

Details

(Keywords: regression)

Attachments

(2 files)

388.24 KB, text/plain
Details
2.98 MB, video/mp4
Details
Attached file logcat_1034.txt
[1.Description]:
[Flame][v2.2&3.0]MT a call, suspend test device to sleep mode. wake it up after several minutes, the time-meter counts time  wrongly.

Found time:10:34
Attchment:logcat_1034.txt,1034.mp4

[2.Testing Steps]: 
1. MT a call.
2.Press power key to lock screen.
3. Wait for some minutes(eg:5min).
4. Wake the device up.

[3.Expected Result]: 
4. The time-meter should work well.

[4.Actual Result]: 
4. The time-meter is displayed with wrong time.

[5.Reproduction build]: 
Device: Flame 2.2 build(Affected)
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Affected)
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,8/10

[7.TCID]: 
Free Test

[8.Note]:
The time on status bar will not update in real time, but show as the time before you lock screen.
Attached video 1034.mp4
[Blocking Requested - why for this release]: I don't repro on 2.1[1]. Visible regression on the Dialer which can cost money to an end user.

[1] Build ID               20150327001204
Gaia Revision          6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gaia Date              2015-03-25 11:16:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f4d7c0e7292e
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880
blocking-b2g: --- → 2.1?
Summary: [Flame][Dialer]The time-meter counts the conversation time wrongly. → [Callscreen] Call duration stops incrementing if the phone falls into sleep mode
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #2)
> [Blocking Requested - why for this release]: I don't repro on 2.1[1].

Addendum: I can repro on master.
Comms Triage: Certification blocker.
blocking-b2g: 2.1? → 2.2+
Assignee: nobody → thills
Target Milestone: --- → 2.2 S9 (3apr)
QA Contact: pcheng
Note: Tamara and I noticed that the counter stops incrementing after about 90 seconds.
jlorenzo: Thanks. That would save me a lot of time in finding the window.
I can repro this all the way back to the first master build on 9-23-14.  Interesting is that on the older builds, the counter stops at 0:07.  Also,  I think you cannot reproduce this problem with the console cable plugged in.
A = issue does NOT repro
B = call duration timer does not work; it always displays 00:00
C = this bug

In central the timeline of behaviors goes from A-->B-->C.
B lasted a little over 2 weeks. Would you like to find the window between A to B, or between B to C, or both?
Flags: needinfo?(thills)
Hi Pi Wei,

I think we would would want both.  Also, is there a bug number for issue B?

Thanks so much,

-tamara
Flags: needinfo?(thills)
Here's my results in KK Central so far:

(builds before this don't repro the bug)
20140915201445 - no repro
20140916170759 - timer not working*
20141003063839 - timer not working
20141005093632 - repro
(builds after this repro the bug)

*timer not working = B of comment 8.

I consulted with Naoki, and he proposed that we come up with a patch that could be applied to get rid of B, so we can find the window for A to C.

I'll try to find the bug for B, if not I'll just proceed with finding the two windows. In the meantime, Tamara, is it possible that you come up with a patch that would fix B?
Flags: needinfo?(thills)
Turns out whatever the bug that caused B to occur was backed out 2 days after it landed on central, so I'm skipping builds that exhibits B and see if I can find anything useful in the pushlog. Clearing NI for now.
Flags: needinfo?(thills)
Caused by bug 1054818.

We can back this patch out, but then systime changes will mess up the time on the Callscreen. I think that's preferable to this bug.
Depends on: 1054818
I'm backing out bug 1054818 to fix this. If we so desire, we can set it to a blocker, but it wouldn't make sense as it never was one.
Removing window-wanted since the cause has been identified. 1054818 is in my Central pushlog as well. I was having difficulty backing out the patch locally so I'll leave this to the devs.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Fixed by the backout of bug 1054818. We should still get verification, though.

Thanks for your investigation, Tamara, and Pi Wei.

Tamara, could you file a bug against the Performance API about this? I talked with Jonas Sicking and he said that the behavior that we were seeing with it is unexpected, especially given that we hold a high priority wake lock during phone calls.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(thills)
Resolution: --- → FIXED
See Also: → 1150766
I can't repro anymore after the back out on 2.2[1] and master[2]. Thank you very much for your effectiveness, guys!

(In reply to Doug Sherk (:drs) (use needinfo?) from comment #13)
> I'm backing out bug 1054818 to fix this. If we so desire, we can set it to a
> blocker, but it wouldn't make sense as it never was one.
I agree. Bug 1054818 is an edge case which was present since 1.3. I'm okay with living with it for the next release. 

Clearing Tamara's nom as bug 1150766 has been filed and linked to this one.

[1] Gaia Revision          022eeb91197ba4a9adfd67bd6db5aa03cc69eb31
Gaia Date              2015-04-03 04:13:03
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d496224fd7ed
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.195523
Firmware Date          Thu Apr  2 19:55:35 EDT 2015
Bootloader             L1TC000118D0

[2] Gaia Revision          16383ec2bf3ed46f893b15b3fab2892e9fadc4e7
Gaia Date              2015-04-03 06:14:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: needinfo?(thills)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.