[Flame][Contacts]The lock icon will disappear after you switch device to landscape.

VERIFIED DUPLICATE of bug 1141832

Status

defect
VERIFIED DUPLICATE of bug 1141832
4 years ago
4 years ago

People

(Reporter: liuke, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame v2.2 & v3.0][Contacts]After you switch device to landscape in log in Gmail account page, the lock icon can't display.
Found time:15:07
See attachment:2015-04-02-15-07-23.png and logcat_1507.txt

[2.Testing Steps]: 
1.Launch Contacts.
2.Tap Settings -> "Import Contacts" -> "Gmail/Facebook/Outlook".
3.Switch device to landscape.

[3.Expected Result]: 
3.The lock icon should still display at left-top.

[4.Actual Result]: 
3. The lock icon at left-top will disappear.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150401002624

Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4

Gaia Date              2015-03-31 21:48:06

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047

Gecko Version          37.0

Device Name            flame

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150401.042225

FirmwareDate           Wed Apr  1 04:22:36 EDT 2015

Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted file logcat_1507.txt
[Blocking Requested - why for this release]: Likely a fallout of bug 1134009. I don't repro on 2.1[1]. Visible regression on the browser.

[1] Build ID               20150327001204
Gaia Revision          6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gaia Date              2015-03-25 11:16:16
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f4d7c0e7292e
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141120.194707
Firmware Date          Thu Nov 20 19:47:17 EST 2014
Bootloader             L1TC00011880
Blocks: 1134009
blocking-b2g: --- → 2.2?
Component: Gaia::Contacts → Gaia::System::Browser Chrome
Keywords: regression
Julien, is the alternative approach we discussed for bug 1134009 going to cover this. Can you assign yourself or should the systemsfe team own this?
Flags: needinfo?(felash)
Yeah, bug 1141832 most certainly covers this issue as well.


You can try the patch there to be sure, but I'm duping right now :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(felash)
Resolution: --- → DUPLICATE
Duplicate of bug: 1141832
Verify me once bug 1141832 lands.
Keywords: verifyme
blocking-b2g: 2.2? → 2.2+
Posted image verify.png
Per comment 5, verify this bug after bug 1141832 lands.
This bug has been verified as "pass" on latest build of Flame v2.2/master,Nexus5 v2.2/master by the STR in comment 0.

Actually result: The lock icon should still display at left-top.
Reproduce rate: 0/5
See attachment: verify.png

Device: Flame 2.2 version(pass):
Build ID               20150614002504
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cfd86c2ba1b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.040237
Firmware Date          Sun Jun 14 04:02:49 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(pass):
Build ID               20150614160203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3c26bef95d54
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.195926
Firmware Date          Sun Jun 14 19:59:37 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(pass):
Build ID               20150614002504
Gaia Revision          cfceba16e48ede3defee24be93637a0fa291c494
Gaia Date              2015-06-11 22:10:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2cfd86c2ba1b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150614.042607
Firmware Date          Sun Jun 14 04:26:25 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(pass):
Build ID               20150614010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150614.044149
Firmware Date          Sun Jun 14 04:42:08 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.