[Browser]The search page cannot hide when PIN code inputting page appear.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: huayu.li, Assigned: etienne)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Posted file logcat3.txt
[1.Description]:
[Nexus5 v2.2&3.0][Flame v2.2&v3.0]While we enable search input box, the PIN code input view displayed, the search view still displayed in foreground and we can search.
Occurence time:17:00
See attachments:logcat3.txt,VIDEO0478.3gp

[2.Testing Steps]: 
Precondition:SIM with a PIN code in device.
1.Launch browser.
2.Tap the address input box and input some words.
3.Long press power key and enable airplane mode.
4.Long press power key and disable airplane mode.
**You can see the PIN input page is displayed in background, the keyboard of PIN page is displayed in foreground,tap on it, the PIN code page still cannot be displayed.
5.Tap the search box and input some words, tap search key.

[3.Expected Result]: 
4&5.The search input box will   hide after PIN code input page displayed.

[4.Actual Result]: 
5.The PIN code input page will be displayed.

[5.Reproduction build]: 
Flame v2.2:[Affected]
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0[Affected]
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2[Affected]
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150401.041913
Firmware Date          Wed Apr  1 04:19:28 EDT 2015
Bootloader             HHZ12d

Nexus5 3.0[Affected]
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150401.192533
Firmware Date          Wed Apr  1 19:25:49 EDT 2015
Bootloader             HHZ12d

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted video VIDEO0478.3gp
blocking-b2g: --- → 2.2+
Component: Gaia::Browser → Gaia::System::Window Mgmt
Alive, Etienne, can you help out here?
Flags: needinfo?(etienne)
Flags: needinfo?(alive)
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Flags: needinfo?(alive)
(Assignee)

Updated

4 years ago
Attachment #8587916 - Flags: review?(alive)
Comment on attachment 8587916 [details] [review]
[gaia] etiennesegonzac:bug-1150456 > mozilla-b2g:master

Interesting case! I will think about if hierarchy management could handle this..
Attachment #8587916 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
Comment on attachment 8587916 [details] [review]
[gaia] etiennesegonzac:bug-1150456 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): rocketbar
[User impact] if declined: See Description, really confusing UX
[Testing completed]: STR from the bug
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8587916 - Flags: approval-gaia-v2.2?
Attachment #8587916 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 8

4 years ago
This issue had been successfully verified on Flame 2.2&3.0 and nexus5 2.2&3.0
Reproducing rate: 0/5


Device: Flame 2.2[Verified]
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2[Verified]
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150407.195148
Firmware Date          Tue Apr  7 19:52:02 EDT 2015
Bootloader             HHZ12d

Device: Flame 3.0[Verified]
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 3.0[Verified]
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150407.192944
Firmware Date          Tue Apr  7 19:30:00 EDT 2015
Bootloader             HHZ12d
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.