Power regression in video playback and video encode (Camcorder)

RESOLVED FIXED in Firefox 40

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ntroast, Assigned: sotaro)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 810348])

Attachments

(1 attachment)

(Reporter)

Updated

4 years ago
Flags: needinfo?(sotaro.ikeda.g)
(Reporter)

Updated

4 years ago
Flags: needinfo?(sushilchauhan)
(Assignee)

Comment 1

4 years ago
It is added as a workaround of codeaurora's OpenGL module. If the problem is already fixed by the OpenGL module. We could remove it.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Updated

4 years ago
Depends on: 1029856
Group: qualcomm-confidential
(Reporter)

Comment 2

4 years ago
We have observed a large power regression in video playback, video encode (Camcorder). bug 1029856 seems to be at fault. With this patch removed we are seeing much better power usage in these cases.

Gecko: 3970b1e517b6447237421c1f9e7845c00bde0838
Gaia: 7f367fc98ffdd183f21d2cdfe20556ab877ece34
Group: qualcomm-confidential
Group: qualcomm-confidential
Group: qualcomm-confidential

Comment 3

4 years ago
Moving NI to Sotaro as the bug https://bugzilla.mozilla.org/show_bug.cgi?id=1029856 was assigned to him.
Flags: needinfo?(sushilchauhan) → needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 4

4 years ago
Sushil, is it ok to remove Bug 1029856 fix? It is a workaround of codeaurora's OpenGL module problem.
Flags: needinfo?(sotaro.ikeda.g) → needinfo?(sushilchauhan)
Whiteboard: [CR 817175]
Whiteboard: [CR 817175] → [caf priority: p2][CR 817175]

Comment 5

4 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> Sushil, is it ok to remove Bug 1029856 fix? It is a workaround of
> codeaurora's OpenGL module problem.

Yes, you can remove patch from Bug https://bugzilla.mozilla.org/show_bug.cgi?id=1029856.
Flags: needinfo?(sushilchauhan)
(Assignee)

Updated

4 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Updated

4 years ago
Attachment #8587770 - Flags: review?(sushilchauhan)

Updated

4 years ago
Attachment #8587770 - Flags: review?(sushilchauhan) → review+
(Assignee)

Updated

4 years ago
(Assignee)

Updated

4 years ago
https://hg.mozilla.org/mozilla-central/rev/f8016d990c69
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)

Updated

4 years ago
Attachment #8587770 - Flags: approval-mozilla-b2g37?

Comment 10

4 years ago
Bhavana -- can you please approve it for 2.2
Flags: needinfo?(bbajaj)
(Reporter)

Updated

4 years ago
Whiteboard: [caf priority: p2][CR 817175] → [caf priority: p2][CR 810348]
Flags: needinfo?(bbajaj)
Attachment #8587770 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.