[RTL][Systems] Parentheses in song title are not displayed correctly on music widget screens

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: tedders1)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Posted image Parenthesis.png
Description:
Song title that contains parentheses is displayed incorrectly on lockscreen and notification tray. This issue also reproduces on Create Ringtone screen and Settings > Sound screen.

Pre-requisite: Have at least 1 song containing parentheses in the title on the device.

Repro Steps:
1) Update a Flame to 20150402063750.
2) Set the device language in Arabic under Settings > Language.
3) Open Music app.
4) Play the song with the parentheses in the title.
5) Pull down the notification tray, or bring the lockscreen by pressing the power button twice.
6) Observe the parentheses in the song title.

Actual:
The parentheses are not located correctly.

Expected:
The parentheses are located correctly.

Note:
- The parentheses are also mis-located on "Create Ringtone" page, and on Settings >  Sound page when the song is set as ringtone.
- The parentheses are displayed correctly within the Music app. See bug 1140154.

Environmental Variables:
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.2.

Result: The parentheses are not located correctly on music widget and ringtone-related screens.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150401162503
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Component: Gaia::System → Gaia::Music
blocking-b2g: --- → 2.2?
Priority: -- → P2
Blocks: 1151496
Created a new bug for ringtone screen issues.
Ted, can you take a look at the music widget?
Assignee: nobody → tclancy
Summary: [RTL][Systems] Parentheses in song title are not displayed correctly on music widget and ringtone-related screens → [RTL][Systems] Parentheses in song title are not displayed correctly on music widget screens
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 3

4 years ago
Hi Yeojin,

Could you please attach the song you were listening to when you took those pictures? Thanks.
Flags: needinfo?(ychung)
(Assignee)

Comment 4

4 years ago
Note to testers:

The trick to reproducing this is that you need a song where the artist's name is in a right-to-left script while the song name is in a left-to-right script. And the song name needs to end with a bracket (parenthesis).
(Reporter)

Comment 5

4 years ago
Sorry, I do not have the exact same file anymore, but the attached file should trigger the issue as well.

I was unable to reproduce this issue on the music widget on today's Flame master. However, I still saw the issue on the ringtone-related screens, such as "Create ringtone" screen, and Settings > Sound.

Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(ychung)
(In reply to Ted Clancy [:tedders1] from comment #3)
> Hi Yeojin,
> 
> Could you please attach the song you were listening to when you took those
> pictures? Thanks.

Hey Ted, actually you can choose any mp3 file and edit the tags with tag editor, like [1]. It should be able to modify any fields then you can test them with your patch. Hope this helps :)

[1] http://kid3.sourceforge.net/
(Assignee)

Updated

4 years ago
Attachment #8588966 - Flags: review?(dflanagan)
(Assignee)

Comment 8

4 years ago
(In reply to Yeojin Chung [:YeojinC] from comment #5)

> Sorry, I do not have the exact same file anymore, but the attached file
> should trigger the issue as well.
> 
> I was unable to reproduce this issue on the music widget on today's Flame
> master. 

Yeojin, this bug only occurs when the Artist name is in a right-to-left script. The file you attached won't trigger the issue.
Comment on attachment 8588966 [details] [review]
[gaia] tedders1:bug-1150749-fix > mozilla-b2g:master

The basic approach looks solid here, but some nits, and r- because of innerHtml which isn't even a thing, and would have been the wrong thing even if it was :-)

Please as Jim (:squib) or Dominic (:dkuo) for the next review, since they are more familiar with this code than I am.
Attachment #8588966 - Flags: review?(dflanagan) → review-
(Assignee)

Updated

4 years ago
Attachment #8588966 - Flags: review- → review?(squibblyflabbetydoo)
Comment on attachment 8588966 [details] [review]
[gaia] tedders1:bug-1150749-fix > mozilla-b2g:master

This looks basically good to me, but I'm not a system app peer (I did write this code originally, though). I'd recommend having someone on the system app take a look at this too.
Attachment #8588966 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 11

4 years ago
Comment on attachment 8588966 [details] [review]
[gaia] tedders1:bug-1150749-fix > mozilla-b2g:master

Adding :etienne to the review since he's a system peer.
Attachment #8588966 - Flags: review+ → review?(etienne)
Target Milestone: --- → 2.2 S10 (17apr)
Comment on attachment 8588966 [details] [review]
[gaia] tedders1:bug-1150749-fix > mozilla-b2g:master

Can you add a small test in apps/system/test/unit/media_playback_test.js to make sure the bdi nodes are created correctly?
r=me with that

Also adding Greg for a quick look at the lockscreen part since the files aren't exactly the same :)
Attachment #8588966 - Flags: review?(gweng)
Attachment #8588966 - Flags: review?(etienne)
Attachment #8588966 - Flags: review+
(Assignee)

Comment 13

4 years ago
Okay, I added a test.
Well I've found the patch is to make them as (almost) the same, so it' good. However, since in System app we need to test every file you patched, so please add one unit test for lockscreen_media_playback.js, thanks.
Flags: needinfo?(tclancy)
(Assignee)

Comment 15

4 years ago
Hi Greg. I've added a test to lockscreen_media_playback.js.
Flags: needinfo?(tclancy)
Comment on attachment 8588966 [details] [review]
[gaia] tedders1:bug-1150749-fix > mozilla-b2g:master

OK thanks.
Attachment #8588966 - Flags: review?(gweng) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 18

4 years ago
Can someone tell me what Autolander's problem is? I've got r+'s from :squib, :etienne, and :gweng. 

:squib is a peer on the Music app, and :etienne is a peer on the system app.

Isn't that enough?
Etienne, could you help with this? Since I'm not owner, and I'm not the recommended reviewer.
Flags: needinfo?(etienne)
(In reply to Ted Clancy [:tedders1] from comment #18)
> Can someone tell me what Autolander's problem is? I've got r+'s from :squib,
> :etienne, and :gweng. 
> 
> :squib is a peer on the Music app, and :etienne is a peer on the system app.
> 
> Isn't that enough?

You removed the review+ from Jim here in comment 11. I recommend getting another review, or landing manually.
Manually landing for now: https://github.com/mozilla-b2g/gaia/commit/a68db278aa7f792c7e9f22b20ca6f160214d6360
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(etienne)
Resolution: --- → FIXED
(Assignee)

Comment 22

4 years ago
Thanks, Kevin.
(Assignee)

Comment 23

4 years ago
Comment on attachment 8588966 [details] [review]
[gaia] tedders1:bug-1150749-fix > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL support (Bug 1064539)

[User impact] if declined:
The text displayed to the use will be jumbled.

[Testing completed]:
Green try run: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=3f78524835d223023589b7378d1f121d8f585dd3

[Risk to taking this patch] (and alternatives if risky):
None forseen. This is a cosmetic change to two screens.

[String changes made]:
None.
Attachment #8588966 - Flags: approval-gaia-v2.2?
Attachment #8588966 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 25

4 years ago
Posted image screenshot.png
This issue has been verified fail on latest build of Flame 2.2/3.0 with the same steps in comment 0.
After step 4, the parentheses of the music title in headers are not located correctly.
But after step 5, the parentheses of the music title are located correctly. 
See attachment:screenshot.png
Rate:5/5

Device: Flame 2.2 (fail)
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (fail)
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.193329
Firmware Date          Sun Apr 19 19:33:40 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]

Comment 26

4 years ago
Hi Josh,
According to comment 25, the parentheses of the music title in headers are not located correctly. Shall we open a new bug to trace it? I think this issue is used for tracing the bug that the parentheses of the music title on music widget screens is shown wrongly in notification tray and lockscreen. And now, the parentheses of the music title in notification tray and lockscreen are located correctly.
Flags: needinfo?(jocheng)
(In reply to Sue from comment #26)
> Hi Josh,
> According to comment 25, the parentheses of the music title in headers are
> not located correctly. Shall we open a new bug to trace it? I think this
> issue is used for tracing the bug that the parentheses of the music title on
> music widget screens is shown wrongly in notification tray and lockscreen.
> And now, the parentheses of the music title in notification tray and
> lockscreen are located correctly.

Lockscreen music widget, utility music widget and Music app are different apps/modules(System and Music), attachment 8594643 [details] is actually showing an issue in Music app, not System app which we have already fixed in this bug, so it's better to file a new bug in Gaia::Music component instead of reopening this one, thanks.
Component: Gaia::Music → Gaia::System
Flags: needinfo?(jocheng)
This issue is verified fixed on Flame 2.2 and 3.0 for the music widget on lockscreen and utility tray.

Device: Flame 2.2
BuildID: 20150420002502
Gaia: c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gecko: cc02ee38b252
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
BuildID: 20150420010204
Gaia: cb41d8421da5dc4f16ea566ea2917a9b7f828154
Gecko: 50b95032152c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

-----

There are still two outstanding issues, one occurs on Settings app > Sound > ringtone (if the song with parentheses is set as ringtone) - this is being covered in bug 1151496.

Another is a partial re-occurrence since bug 1140154 - that parentheses are not displayed correctly while viewing the song in Music app. I have filed bug 1156571 for follow-up on that issue and hope that this covers all scenarios in Music app.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+] → [QAnalyst-Triage?][rtl-impact][MGSEI-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact][MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Flags: needinfo?(ktucker)

Comment 29

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/16256/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.