Closed Bug 1150785 Opened 8 years ago Closed 8 years ago

onloadedmetadata never fired under Firefox 37 for Ubuntu (getUserMedia)

Categories

(Core :: WebRTC: Audio/Video, defect)

37 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1149494
Tracking Status
firefox37 --- affected
firefox38 --- affected
firefox39 --- affected
firefox40 --- affected

People

(Reporter: michael.heuberger, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150328223854

Steps to reproduce:

Visit www.videomail.io with the latest Firefox version 37 for Ubuntu and see, the webcam video feed is not turning up. 

It worked fine for older versions and works fine for Chrome.


Actual results:

After some debugging I found out that the loadedmetadata event is not fired for the video element once source has been assigned.


Expected results:

It should fire the loadedmetadata event so that I can call play() on it.
According to documentation in https://developer.mozilla.org/en-US/docs/Web/API/Navigator/getUserMedia the onloadedmetadata must be called.

This leads me to the assumption that you do not have any unit tests coverage for that. Please add this to your unit tests as well. Thanks heaps!
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]: Regression since Firefox37, but it is worth to fin for next esr38.

Regression pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e329c7fe4c4e&tochange=654e15b4dc9b

Regressed by: Bug 879717
Blocks: 879717
Status: UNCONFIRMED → NEW
Component: Untriaged → WebRTC: Audio/Video
Ever confirmed: true
Flags: needinfo?(pehrsons)
Keywords: regression
OS: Linux → All
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149494
Flags: needinfo?(pehrsons)
You need to log in before you can comment on or make changes to this bug.