bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Remove unused images in /toolkit/themes/*/global/icons/

RESOLVED FIXED in Firefox 40

Status

()

Toolkit
Themes
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dao, Assigned: James Lai, Mentored)

Tracking

Trunk
mozilla40
Points:
---
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(firefox40 fixed)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Since we redesigned the find bar in bug 776708, the following icons became unused and should be removed:

/toolkit/themes/linux/global/icons/find.png
/toolkit/themes/linux/global/icons/wrap.png
/toolkit/themes/windows/global/icons/find.png
/toolkit/themes/windows/global/icons/find-XP.png
/toolkit/themes/windows/global/icons/wrap.png
/toolkit/themes/windows/global/icons/wrap-XP.png

Also need to remove the references to them from these JAR manifests:

/toolkit/themes/linux/global/jar.mn
/toolkit/themes/windows/global/jar.mn
(Reporter)

Comment 1

3 years ago
Unused as well (not all of them are referenced in a jar.mn):

/toolkit/themes/osx/global/icons/error-24.png
/toolkit/themes/osx/global/icons/question-24.png
/toolkit/themes/osx/global/icons/warning-24.png
/toolkit/themes/windows/global/icons/error-24.png
/toolkit/themes/windows/global/icons/error-24-XP.png
/toolkit/themes/windows/global/icons/error-48.png
/toolkit/themes/windows/global/icons/error-48-XP.png
/toolkit/themes/windows/global/icons/errorBar-30.png
/toolkit/themes/windows/global/icons/errorBar-30-aero.png
/toolkit/themes/windows/global/icons/errorBar-60.png
/toolkit/themes/windows/global/icons/errorBar-60-aero.png
/toolkit/themes/windows/global/icons/errorBarIcon-16.png
/toolkit/themes/windows/global/icons/errorBarIcon-16-aero.png
/toolkit/themes/windows/global/icons/errorGhosted-64.png
/toolkit/themes/windows/global/icons/errorGhosted-64-aero.png
/toolkit/themes/windows/global/icons/information-48.png
/toolkit/themes/windows/global/icons/information-48-XP.png
/toolkit/themes/windows/global/icons/information-64.png
/toolkit/themes/windows/global/icons/information-64-XP.png
/toolkit/themes/windows/global/icons/informationBarIcon-16.png
/toolkit/themes/windows/global/icons/informationBarIcon-16-aero.png
/toolkit/themes/windows/global/icons/informationGhosted-64.png
/toolkit/themes/windows/global/icons/informationGhosted-64-aero.png
/toolkit/themes/windows/global/icons/question-24.png
/toolkit/themes/windows/global/icons/question-24-XP.png
/toolkit/themes/windows/global/icons/question-48.png
/toolkit/themes/windows/global/icons/question-48-XP.png
/toolkit/themes/windows/global/icons/questionBarIcon-16.png
/toolkit/themes/windows/global/icons/questionBarIcon-16-aero.png
/toolkit/themes/windows/global/icons/questionGhosted-64.png
/toolkit/themes/windows/global/icons/questionGhosted-64-aero.png
/toolkit/themes/windows/global/icons/warning-24.png
/toolkit/themes/windows/global/icons/warning-24-XP.png
/toolkit/themes/windows/global/icons/warningBar-30.png
/toolkit/themes/windows/global/icons/warningBar-30-aero.png
/toolkit/themes/windows/global/icons/warningBar-60.png
/toolkit/themes/windows/global/icons/warningBar-60-aero.png
/toolkit/themes/windows/global/icons/warningBarIcon-16.png
/toolkit/themes/windows/global/icons/warningBarIcon-16-aero.png
/toolkit/themes/windows/global/icons/warningGhosted-64.png
/toolkit/themes/windows/global/icons/warningGhosted-64-aero.png
Summary: Remove unused images: wrap.png, wrap-XP.png, find.png, find-XP.png → Remove unused images in /toolkit/themes/*/global/icons/

Comment 2

3 years ago
Hi Dao,

I am interested in this bug, do the unused pictures in your second comment need checking in the .mn file, and if they aren't, is it just a case of removing the file?. And if they are located in mn file, then we remove the file and the reference to the picture?

Thanks

Jesal
Flags: needinfo?(dao)

Comment 3

3 years ago
Created attachment 8588554 [details] [diff] [review]
bug1150800.patch - removal of pictures and references

Hi Dao, I have just attached this patch, could you check it please and see if its correct?
(Reporter)

Comment 4

3 years ago
Comment on attachment 8588554 [details] [diff] [review]
bug1150800.patch - removal of pictures and references

>@@ -287,44 +278,43 @@ toolkit.jar:
> % override chrome://global/skin/dirListing/local.png              chrome://global/skin/dirListing/local-aero.png             osversion>=6
> % override chrome://global/skin/dirListing/remote.png             chrome://global/skin/dirListing/remote-aero.png            osversion>=6
> % override chrome://global/skin/dirListing/up.png                 chrome://global/skin/dirListing/up-aero.png                osversion>=6
> % override chrome://global/skin/icons/autoscroll.png              chrome://global/skin/icons/autoscroll-aero.png             osversion>=6
> % override chrome://global/skin/icons/blacklist_favicon.png       chrome://global/skin/icons/blacklist_favicon-aero.png      osversion>=6
> % override chrome://global/skin/icons/blacklist_large.png         chrome://global/skin/icons/blacklist_large-aero.png        osversion>=6
> % override chrome://global/skin/icons/Error.png                   chrome://global/skin/icons/Error-aero.png                  osversion>=6
> % override chrome://global/skin/icons/error-16.png                chrome://global/skin/icons/error-16-aero.png               osversion>=6
>-% override chrome://global/skin/icons/error-24.png                chrome://global/skin/icons/error-24-aero.png               osversion>=6
>-% override chrome://global/skin/icons/error-48.png                chrome://global/skin/icons/error-48-aero.png               osversion>=6
>+% override               chrome://global/skin/icons/error-24-aero.png               osversion>=6
>+% override                chrome://global/skin/icons/error-48-aero.png               osversion>=6
> % override chrome://global/skin/icons/error-64.png                chrome://global/skin/icons/error-64-aero.png               osversion>=6
>-% override chrome://global/skin/icons/find.png                    chrome://global/skin/icons/find-aero.png                   osversion>=6
>+% override                  chrome://global/skin/icons/find-aero.png                   osversion>=6
> % override chrome://global/skin/icons/folder-item.png             chrome://global/skin/icons/folder-item-aero.png            osversion>=6
> % override chrome://global/skin/icons/information-16.png          chrome://global/skin/icons/information-16-aero.png         osversion>=6
> % override chrome://global/skin/icons/information-24.png          chrome://global/skin/icons/information-24-aero.png         osversion>=6
> % override chrome://global/skin/icons/information-32.png          chrome://global/skin/icons/information-32-aero.png         osversion>=6
>-% override chrome://global/skin/icons/information-48.png          chrome://global/skin/icons/information-48-aero.png         osversion>=6
>-% override chrome://global/skin/icons/information-64.png          chrome://global/skin/icons/information-64-aero.png         osversion>=6
>+% override           chrome://global/skin/icons/information-64-aero.png         osversion>=6
> % override chrome://global/skin/icons/Print-preview.png           chrome://global/skin/icons/Print-preview-aero.png          osversion>=6
> % override chrome://global/skin/icons/Portrait.png                chrome://global/skin/icons/Portrait-aero.png               osversion>=6
> % override chrome://global/skin/icons/Landscape.png               chrome://global/skin/icons/Landscape-aero.png              osversion>=6
> % override chrome://global/skin/icons/Question.png                chrome://global/skin/icons/Question-aero.png               osversion>=6
> % override chrome://global/skin/icons/question-16.png             chrome://global/skin/icons/question-16-aero.png            osversion>=6
>-% override chrome://global/skin/icons/question-24.png             chrome://global/skin/icons/question-24-aero.png            osversion>=6
>-% override chrome://global/skin/icons/question-48.png             chrome://global/skin/icons/question-48-aero.png            osversion>=6
>+% override           chrome://global/skin/icons/question-24-aero.png            osversion>=6
>+% override           chrome://global/skin/icons/question-48-aero.png            osversion>=6
> % override chrome://global/skin/icons/question-64.png             chrome://global/skin/icons/question-64-aero.png            osversion>=6
> % override chrome://global/skin/icons/Search-close.png            chrome://global/skin/icons/Search-close-aero.png           osversion>=6
> % override chrome://global/skin/icons/Search-glass.png            chrome://global/skin/icons/Search-glass-aero.png           osversion>=6
> % override chrome://global/skin/icons/sslWarning.png              chrome://global/skin/icons/sslWarning-aero.png             osversion>=6
> % override chrome://global/skin/icons/Warning.png                 chrome://global/skin/icons/Warning-aero.png                osversion>=6
> % override chrome://global/skin/icons/warning-large.png           chrome://global/skin/icons/warning-large-aero.png          osversion>=6
> % override chrome://global/skin/icons/warning-16.png              chrome://global/skin/icons/warning-16-aero.png             osversion>=6
>-% override chrome://global/skin/icons/warning-24.png              chrome://global/skin/icons/warning-24-aero.png             osversion>=6
>+% override             chrome://global/skin/icons/warning-24-aero.png             osversion>=6
> % override chrome://global/skin/icons/warning-64.png              chrome://global/skin/icons/warning-64-aero.png             osversion>=6
> % override chrome://global/skin/icons/windowControls.png          chrome://global/skin/icons/windowControls-aero.png         osversion>=6
>-% override chrome://global/skin/icons/wrap.png                    chrome://global/skin/icons/wrap-aero.png                   osversion>=6
>+% override                   chrome://global/skin/icons/wrap-aero.png                   osversion>=6
> % override chrome://global/skin/printpreview/arrow-left.png       chrome://global/skin/printpreview/arrow-left-aero.png      osversion>=6
> % override chrome://global/skin/printpreview/arrow-left-end.png   chrome://global/skin/printpreview/arrow-left-end-aero.png  osversion>=6
> % override chrome://global/skin/printpreview/arrow-right.png      chrome://global/skin/printpreview/arrow-right-aero.png     osversion>=6
> % override chrome://global/skin/printpreview/arrow-right-end.png  chrome://global/skin/printpreview/arrow-right-end-aero.png osversion>=6
> % override chrome://global/skin/toolbar/spring.png                chrome://global/skin/toolbar/spring-aero.png               osversion>=6
> % override chrome://global/skin/tree/sort-asc.png                 chrome://global/skin/tree/sort-asc-aero.png                osversion>=6
> % override chrome://global/skin/tree/sort-dsc.png                 chrome://global/skin/tree/sort-dsc-aero.png                osversion>=6
> % override chrome://global/skin/tree/twisty-clsd.png              chrome://global/skin/tree/twisty-clsd-aero.png             osversion>=6

You need to completely remove these lines that you modified here.

Also, your file removals don't show up in this patch. You probably need to run hg addremove?

Looks good otherwise.
Flags: needinfo?(dao)

Comment 5

3 years ago
Created attachment 8589623 [details] [diff] [review]
bug1150800 Patch 2

Hi Dao,

I have removed the extra lines you have said and ran the hgaddremove command to showcase the file changes, please could you review this to see if this patch does the job?

Thanks

Jesal
Flags: needinfo?(dao)
(Reporter)

Comment 6

3 years ago
You removed all the lines, but you should only remove those referencing the removed files ;)

And it seems that you've missed those files:

/toolkit/themes/windows/global/icons/error-24-XP.png
/toolkit/themes/windows/global/icons/error-48-XP.png
/toolkit/themes/windows/global/icons/information-48-XP.png
/toolkit/themes/windows/global/icons/information-64-XP.png
/toolkit/themes/windows/global/icons/question-24-XP.png
/toolkit/themes/windows/global/icons/question-48-XP.png
/toolkit/themes/windows/global/icons/warning-24-XP.png
Flags: needinfo?(dao)

Comment 7

3 years ago
Hi Dao, 

oh yes sorry, will have another look and right another patch.
Just had a look at the files that I have missed, it seems they are missing from my build?
I assumed they were already removed?

Thanks

Jesal
Flags: needinfo?(dao)
(Reporter)

Comment 8

3 years ago
No, they should still be in the current source tree, for example this one:

http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/icons/error-24-XP.png
Flags: needinfo?(dao)

Comment 9

3 years ago
Hi Dao, I have just reinstalled the codebase and the -xp icons are still missing, are they available in another build?
Flags: needinfo?(dao)
(Reporter)

Comment 10

3 years ago
They should be right there in the mozilla-central code base under toolkit/themes/windows/global/icons/, no building process should be needed.
Flags: needinfo?(dao)

Updated

3 years ago
Duplicate of this bug: 1154658
(Reporter)

Comment 12

3 years ago
Jesal, still no luck finding these images? Can you describe how exactly you tried to find them?

Getting the code base is just one command:

$ hg clone https://hg.mozilla.org/mozilla-central/ src

And then ls or dir should list the images:

$ dir src/toolkit/themes/windows/global/icons/
Flags: needinfo?(kjjcrm1)
(Reporter)

Updated

3 years ago
Flags: firefox-backlog+
(Reporter)

Updated

3 years ago
Attachment #8588554 - Attachment is obsolete: true
(Reporter)

Updated

3 years ago
Attachment #8589623 - Attachment is obsolete: true
(Reporter)

Comment 13

3 years ago
Let's see if someone else wants to give this a try.
Flags: needinfo?(kjjcrm1)
(Assignee)

Comment 14

3 years ago
Hi Dao,

I would like to try fixing this bug.
(Assignee)

Comment 15

3 years ago
Created attachment 8597719 [details] [diff] [review]
patch 1st attempt

Just attached the patch. Appreciate if you may help check?
(Reporter)

Comment 16

3 years ago
Comment on attachment 8597719 [details] [diff] [review]
patch 1st attempt

Looks good! Thanks!
Attachment #8597719 - Flags: review+
(Reporter)

Updated

3 years ago
Assignee: nobody → jlaiosd
https://hg.mozilla.org/mozilla-central/rev/dc320dca955d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40

Updated

3 years ago
Iteration: --- → 40.2 - 27 Apr
Flags: qe-verify?
(Reporter)

Updated

3 years ago
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.