[Flame][Dialer] Extra buttons are displayed on the known and unknown contact's call information views.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: drs)

Tracking

({regression})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(6 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Flame][v2.2& v3.0][Dialer]Launch Dialer and make an known call and an unknown call, on an known contact's call information screen, the "Add to existing contact" and "Create new contact" buttons will be displayed. On an unknown contact's call information screen, the "Contact details"  button will be displayed.
See attachment: logcat_1500.txt & Video2.MP4
Found at: 15:00

[2.Testing Steps]: 
1. Launch Phone app and enter Dialer view.
2. Make an known call.
3. Make an unknown call.
4.Switch to Call log view.
5. Long Press the known call and select "Call Information".
6. Long Press the unknown call and select "Call Information".

[3.Expected Result]: 
5. The "Add to existing contact" and "Create new contact" buttons could not be displayed.
6. The "Contact details" button could not be displayed.

[4.Actual Result]: 
5. The "Add to existing contact" and "Create new contact" buttons will be displayed.
6. The "Contact details"  will be displayed.

[5.Reproduction build]: 
Device: Flame 2.1 (Unaffected)
Build ID               20150402161201
Gaia Revision          4e7d880defb83c25b49462479c02b3e64d21f421
Gaia Date              2015-04-02 18:26:54
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/e76f5e7a264d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.194043
Firmware Date          Thu Apr  2 19:40:52 EDT 2015
Bootloader             L1TC000118D0

Flame 2.2 (Affected)
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Affected)
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This problem cannot be reproduced on Flame2.1.
Reporter

Comment 1

4 years ago
Posted file logcat_1500.txt
Reporter

Comment 2

4 years ago
Posted video Video2.MP4
[Blocking Requested - why for this release]: Broken functionality on a standard use case.
blocking-b2g: --- → 2.2?
Note: I repro'd this issue on the latest master with regular phone numbers.
Assignee

Comment 5

4 years ago
Caused by bug 1139179.
Depends on: 1139179
Assignee

Updated

4 years ago
Assignee: nobody → drs
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
Assignee

Comment 7

4 years ago
Whoops.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 9

4 years ago
Comment on attachment 8587986 [details] [diff] [review]
Fix extra call info buttons being displayed due to `display` property overriding `hidden` attribute.

Johan, could you verify this before we land it?
Attachment #8587986 - Flags: qa-approval?(jlorenzo)
Comment on attachment 8587986 [details] [diff] [review]
Fix extra call info buttons being displayed due to `display` property overriding `hidden` attribute.

Hi Doug,

It looks good and fixes it for me.  I tested out bug 1139179 as well and I didn't see any obvious breakages of that fix due to this change.

Thanks,
-tamara
Attachment #8587986 - Flags: review?(thills) → review+
qawanted to test around the gaia patch.
Keywords: qawanted
Comment on attachment 8587986 [details] [diff] [review]
Fix extra call info buttons being displayed due to `display` property overriding `hidden` attribute.

Sorry, I won't have time to test it before FC. The QAnalysts are on it per comment 11.
Attachment #8587986 - Flags: qa-approval?(jlorenzo)
QA Contact: ychung
Keywords: qaurgent
blocking-b2g: 2.2? → 2.2+
Posted image PatchApplied.png
The issue no longer occurs after the patch is applied to the latest Flame 3.0. With a known contact, "Contact details" button appears. With a unknown contact, "Add to existing contact" and "Create new contact" buttons appear. No issue has been found with the patch.
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qaurgent, qawanted
QA Contact: ychung
Assignee

Updated

4 years ago
Attachment #8587985 - Flags: review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Assignee

Comment 14

4 years ago
Comment on attachment 8587986 [details] [diff] [review]
Fix extra call info buttons being displayed due to `display` property overriding `hidden` attribute.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1139179
[User impact] if declined: All contact buttons in Dialer call info page will always appear, regardless of whether a call is associated with a contact or not.
[Testing completed]: Tamara, Yeojin, and I all tested this.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8587986 - Flags: approval-gaia-v2.2?
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Please verify this again on Monday Yeojin.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(ychung)
Keywords: verifyme
Attachment #8587986 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master.

Result: With a known contact, "Contact details" button appears. With a unknown contact, "Add to existing contact" and "Create new contact" buttons appear.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150406010204
Gaia: ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Gecko: 4fe763cbe196
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

=======================================
Leaving verifyme for Flame 2.2 uplift & verification.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Reporter

Comment 19

4 years ago
This problem is verified pass on latest build of Flame2.2 by the STR in comment 0.
Actual result: On a known contact call information view, the "Contact details" button is displayed. On an unknown contact call information view, "Add to existing contact" and "Create new contact" buttons are displayed.
See attachment: Verify_screenshot.png
Rate: 0/5

Device: Flame 2.2(Pass)
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.