Search activity does not follow SOCKS proxy setttings

RESOLVED DUPLICATE of bug 507641

Status

Firefox for Android Graveyard
Search Activity
RESOLVED DUPLICATE of bug 507641
3 years ago
5 months ago

People

(Reporter: D Mogle, Unassigned)

Tracking

38 Branch
All
Android

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0

Steps to reproduce:

1. Setup Firefox SOCKS proxy to Orbot
2. Use the search activity to get my IP address (I used duckduckgo).


Actual results:

My actual IP address was returned.


Expected results:

The search activity should search through the SOCKS proxy as configured in Firefox, resulting in the IP of the Tor exit node returning instead of my actual IP.
OS: Linux → Android
Hardware: x86_64 → All

Comment 1

3 years ago
I can confirm proxy settings as described here are not respected:

i) Using the about:config feature
Launch the Firefox browser, and then type “about:config” in the address bar and press return.
Enter “proxy.http” into the search box on the about:config page.
Tap Modify on “network.proxy.http” and type the proxy server name/ip address into the text box.
Tap Modify on “network.proxy.http_port” and type the port number into the number box.Firefox Browser Proxy Settings
Enter “network.proxy.type” into the search box on the about:config page.
Tap Modify on “network.proxy.type” and input the number 1.
Firefox Browser Proxy Settings
Note: To configure proxy servers for SSL, kindly enter “proxy.ssl” in step 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507641

Updated

5 months ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.