Closed Bug 1150952 Opened 5 years ago Closed 5 years ago

New private browsing window should have "Search or enter address" in title

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S10 (17apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: djabber, Assigned: kgrandon)

Details

(Whiteboard: [systemsfe])

Attachments

(3 files, 1 obsolete file)

STR: 
1) Open a new private browsing window

Expected (according to spec): Title in rocket bar should read "Search or enter address"
Actual: Title reads: "Private window"

I think it's clear enough that we're in a private browsing window. Keeping "search or enter address" in the rocket bar serves a good prompt to the user about what to do next.
Whiteboard: [systemsfe]
Not sure if this is a regression or what. I think the probably happens because we set the title this way so it would appear as "Private Window" in the task manager. Need to be sure we don't regress that case.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Comment on attachment 8588270 [details] [review]
[gaia] KevinGrandon:bug_1150952_private_window_landing_title > mozilla-b2g:master

Ben - since you've dealt with some of the title stuff in the past, could you review this if you get a chance? I've gone ahead and reused the _gotName attribute here to prevent changing it to the URL when the page loads. It's not quite what was intended for, but it does exactly what we need to do, and I think it's cleaner than adding *yet* another variable to track this. Thanks!
Attachment #8588270 - Flags: review?(bfrancis)
This is fairly minor, but it is a problem with a new 2.2 feature UX, so requesting blocking.
blocking-b2g: --- → 2.2?
Is this a late string?
Terrible UX.
blocking-b2g: 2.2? → 2.2+
(In reply to Gregor Wagner [:gwagner] from comment #5)
> Is this a late string?

It's not a late string at all, it's just re-using an existing one we already had. No late-l10n needed.
Comment on attachment 8588270 [details] [review]
[gaia] KevinGrandon:bug_1150952_private_window_landing_title > mozilla-b2g:master

Or Etienne, maybe you could review this if you have a minute? Thanks!
Attachment #8588270 - Flags: review?(etienne)
Comment on attachment 8588270 [details] [review]
[gaia] KevinGrandon:bug_1150952_private_window_landing_title > mozilla-b2g:master

Sorry for the delay Kevin, this is a little hacky but it looks like an improvement.

It doesn't seem right that the start page gets included in the session history for the window, perhaps we can file a polish bug to explore whether there's a better way of doing this.
Attachment #8588270 - Flags: review?(etienne)
Attachment #8588270 - Flags: review?(bfrancis)
Attachment #8588270 - Flags: review+
(In reply to Ben Francis [:benfrancis] from comment #9)
> It doesn't seem right that the start page gets included in the session
> history for the window, perhaps we can file a polish bug to explore whether
> there's a better way of doing this.

Thanks for the review Ben. Yeah - it is unfortunate that the start page is included in the history. We should definitely try to prevent that, or maybe implement the page fully to spec, which it is currently not. In the fully speced version, the browser landing page turns into the private browser, instead of launching a new window.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8590033 [details] [review]
[gaia] KevinGrandon:bug_1150952_private_browser_follow_up_title > mozilla-b2g:master

*Sigh* I managed to use the wrong string for this. Here's a follow-up which uses the correct string. It should also be uplifted, or I can squash it into a single patch for v2.2. R=me for the simple string change.
Attachment #8590033 - Flags: review+
Comment on attachment 8590037 [details] [review]
[gaia] KevinGrandon:bug_1150952_uplift > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Missing from feature implementation.
[User impact] if declined: Poor UX for new feature.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, contained to browser.
[String changes made]: None.
Attachment #8590037 - Flags: approval-gaia-v2.2?(bbajaj)
Comment on attachment 8590033 [details] [review]
[gaia] KevinGrandon:bug_1150952_private_browser_follow_up_title > mozilla-b2g:master

This patch cause Gu failed. See Bug 1152705.

05:24:28     INFO -  TEST-UNEXPECTED-FAIL | system/test/unit/app_chrome_test.js | system/AppChrome Old Navigation - Application events app location is changed - private browser landing page - expected 'search-or-enter-address' to equal 'search-the-web'
(In reply to Kevin Grandon :kgrandon from comment #14)
> Follow-up in master:
> https://github.com/mozilla-b2g/gaia/commit/
> cdf52760998d3c4c8573790de7a4bf5c0068ec7f

reverted for the Gu bustage like mentioned in comment #17
Status: RESOLVED → REOPENED
Flags: needinfo?(kgrandon)
Resolution: FIXED → ---
Attachment #8590033 - Attachment is obsolete: true
Flags: needinfo?(kgrandon)
Follow-up in master: https://github.com/mozilla-b2g/gaia/commit/89ffba69bc0a3830181358f942a263f2734cfccc
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Attachment #8590037 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S10 (17apr)
Kevin, I saw the title is "Search the Web" on master build. Could you check it?

On v2.2 build, the title is "Search or enter address" which is correct.

*master
Build ID               20150412160203
Gaia Revision          3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gaia Date              2015-04-10 14:38:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a46652bd992
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.192808
Firmware Date          Sun Apr 12 19:28:21 EDT 2015
Bootloader             L1TC000118D0

*v2.2
Build ID               20150412162502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.200029
Firmware Date          Sun Apr 12 20:00:40 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(kgrandon)
Hermes - 

Can you try re-verifying on a more recent build? The gaia revision in your verification test seems to be old. Please try with something newer than the 4/13 build. Thanks!

(Note: I also tried flashing with the b2g flash tool, but it's giving me old builds for some reason)
Flags: needinfo?(kgrandon) → needinfo?(hcheng)
Kevin, 
You are right. 4/13 used a old gaia.
Re-verified master with below build.

* master
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.