Port Bug 674779 to comm-central - Add per-compartment CPU accounting

RESOLVED FIXED in Firefox 40

Status

MailNews Core
Build Config
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aryx, Assigned: aryx)

Tracking

Trunk
Thunderbird 40.0

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(3 attachments)

Created attachment 8588080 [details] [diff] [review]
tb part, v1

Bug 674779 adds about:performance. From bug 674779 comment 149
> It's a top-like tool that displays for each webpage and add-on the amount of CPU, system time, CPOW time, jank during the latest n milliseconds. For the moment, that's only for JS code (including native code called by JS). In future versions, I hope to add memory use and plug-in use.
> 
> This feature is Nightly-only for the time being, with no definite plans to let it ride the trains. For the moment, the intended users are 1/ us; 2/ add-on developers. I hope to eventually make this useful for power users, but this will require UX and l10n work.

This would not directly accessible if your application hasn't a location bar (I altered a link on about:support to test it, Error console input can also open it from JavaScript).
Attachment #8588080 - Flags: review?(mkmelin+mozilla)
Attachment #8588081 - Flags: review?(clokep) → review+

Comment 3

3 years ago
Comment on attachment 8588080 [details] [diff] [review]
tb part, v1

Review of attachment 8588080 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/installer/package-manifest.in
@@ +543,5 @@
>  #endif
>  @RESPATH@/components/toolkit_asyncshutdown.xpt
>  @RESPATH@/components/toolkit_filewatcher.xpt
>  @RESPATH@/components/toolkit_formautofill.xpt
> +@RESPATH@/components/toolkit_perfmonitoring.xpt

nit: i think the convention is to have these be in alphabetical order, so move it down one row
Attachment #8588080 - Flags: review?(mkmelin+mozilla) → review+

Updated

3 years ago
Duplicate of this bug: 1151789

Comment 5

3 years ago
Comment on attachment 8588082 [details] [diff] [review]
suite part, v1

r=me Also a=CLOSED TREE for SeaMonkey
Attachment #8588082 - Flags: review?(neil) → review+
http://hg.mozilla.org/comm-central/rev/e2cdfef448c1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0
You need to log in before you can comment on or make changes to this bug.