Closed Bug 1151259 Opened 6 years ago Closed 6 years ago

white thick border on button bar on linux developer tools inspector

Categories

(DevTools :: Inspector, defect)

40 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(firefox37 unaffected, firefox38 fixed, firefox39 fixed, firefox40 fixed)

RESOLVED FIXED
Firefox 40
Tracking Status
firefox37 --- unaffected
firefox38 --- fixed
firefox39 --- fixed
firefox40 --- fixed

People

(Reporter: jorrete, Assigned: bgrins)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image dark_theme_border.png
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150327124350

Steps to reproduce:

Open the developer tools inspector


Actual results:

there is white border on top and bottom (3px aprox) of the button bar


Expected results:

no white border on the dark them and also the border is too thick
Component: Untriaged → Developer Tools: Inspector
Summary: white thick border on button bar of developer tools inspector → white thick border on button bar on linux developer tools inspector
I can confirm this happens in Nightly (40) on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The bug appears to be present in 38 - 40, but 37 appears correctly.

It looks like <toolbar> has a default style of padding: 2px 0[1] on Linux only which leads to this.  However, that styling has been present for many years, so it can't be the root cause.

Brian, any guess what might have introduced this?

[1]: https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/toolbar.css#23
Flags: needinfo?(bgrinstead)
Got a regression range of: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2b6bd6b2dfb6&tochange=369a8f14ccf8.

Most likely candidate seems to be https://hg.mozilla.org/integration/mozilla-inbound/rev/0d7bbd6633c3 (Bug 1101569), which changed the way those sidebar tabs are generated.

The other changeset that landed in that bug was includes the line that introduces the toolbar: https://hg.mozilla.org/mozilla-central/rev/e40dfb7e4ec7#l1.131.
Blocks: 1101569
Flags: needinfo?(bgrinstead)
Here is the toolbar element: https://dxr.mozilla.org/mozilla-central/source/browser/devtools/framework/sidebar.js#123.  I don't see any styles that are intended to apply to this.  If that's the case, the easiest fix would be to just switch that to be a box element.  Patrick, any reason in particular this is a toolbar or can it be switched?
Flags: needinfo?(pbrosset)
(In reply to Brian Grinstead [:bgrins] from comment #4)
> Here is the toolbar element:
> https://dxr.mozilla.org/mozilla-central/source/browser/devtools/framework/
> sidebar.js#123.  I don't see any styles that are intended to apply to this. 
> If that's the case, the easiest fix would be to just switch that to be a box
> element.  Patrick, any reason in particular this is a toolbar or can it be
> switched?
As long as the <toolbarbutton> in that toolbar still works, this can be anything at all.
Flags: needinfo?(pbrosset)
Attached patch tabs-container.patch (obsolete) — Splinter Review
Does this do the trick?

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4463030d9ed3
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8589111 - Flags: review?(jryans)
Comment on attachment 8589111 [details] [diff] [review]
tabs-container.patch

Looks like there are some test failures due to the element changing
Attachment #8589111 - Flags: review?(jryans)
This is looking better: https://treeherder.mozilla.org/#/jobs?repo=try&revision=03444007ee74
Attachment #8589111 - Attachment is obsolete: true
Attachment #8589304 - Flags: review?(jryans)
Comment on attachment 8589304 [details] [diff] [review]
tabs-container.patch

Review of attachment 8589304 [details] [diff] [review]:
-----------------------------------------------------------------

Great, works well here!
Attachment #8589304 - Flags: review?(jryans) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/77303df92deb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
Comment on attachment 8589304 [details] [diff] [review]
tabs-container.patch

Approval Request Comment
[Feature/regressing bug #]: 1101569
[User impact if declined]: On Linux there is an ugly border in the Inspector and Netmonitor panels in devtools
[Describe test coverage new/current, TreeHerder]: None, markup change only
[Risks and why]: Low risk, changing a <toolbar> element to a <box> in the sidebar.
[String/UUID change made/needed]:
Attachment #8589304 - Flags: approval-mozilla-beta?
Attachment #8589304 - Flags: approval-mozilla-aurora?
Comment on attachment 8589304 [details] [diff] [review]
tabs-container.patch

Should be in 38 beta 5.
Attachment #8589304 - Flags: approval-mozilla-beta?
Attachment #8589304 - Flags: approval-mozilla-beta+
Attachment #8589304 - Flags: approval-mozilla-aurora?
Attachment #8589304 - Flags: approval-mozilla-aurora+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.