Display corruption if hardware acceleration enabled on Firefox 37.0.1, not just with D2D 1.1

ASSIGNED
Assigned to

Status

()

Core
Graphics
--
major
ASSIGNED
3 years ago
a year ago

People

(Reporter: Aditya, Assigned: jrmuizel, NeedInfo)

Tracking

({regression})

37 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8588496 [details]
Animated gif showing the display corruption

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

1. Create a new firefox profile (clean profile) and by default Hardware acceleration is enabled then start firefox
2. Opened a tab (any website)
3. Opened another tab (any website) so in total there are 3 tabs
4. Just hover mouse at each tab AND/OR switch between tab


Actual results:

- Typing at the address bar often would result in display corruption at the address bar so it's hard to know what you just typed
- Display corruptions like for example in the gif attached a page from another tab being displayed in current tab (as can be seen from the gif attached)

Note: if you see a tab being highlighted in the gif that means that i'm currently mouse hovering at the tab


Expected results:

Everything should be working fine without display corruption. I reverted to Firefox 36.0.4 even with hardware acceleration enabled i don't experience such problem there
(Reporter)

Comment 1

3 years ago
I forgot to mention this in the previous post. I'm using:

- Radeon HD 7730
- AMD Omega Driver 14.12 (which is the latest at the time i write this)

Comment 2

3 years ago
Type about:support in the location bar and paste the section "graphics", please.
Component: Untriaged → Graphics
Flags: needinfo?(adityaw321)
Product: Firefox → Core
(Reporter)

Comment 3

3 years ago
Here's the graphics information from the about:support page.

Adapter Description	AMD Radeon HD 7700 Series
Adapter Drivers	aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	2048
ClearType Parameters	Gamma: 2400 Pixel Structure: R ClearType Level: 0 Enhanced Contrast: 200
Device ID	0x6837
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	11-20-2014
Driver Version	14.501.1003.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	23301787
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon HD 7700 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(adityaw321)
Jeff, this looks like a duplicate of bug 1067470, but I don't know if the configuration helps with more info.
Flags: needinfo?(jmuizelaar)
Whiteboard: gfx-noted
(Reporter)

Comment 5

3 years ago
Just wanted to let you guys know that the problem persist even on 38 beta (tested on 38.0.4 and 38.0.5 beta with clean profile). Firefox totally unusable because of this so i'm still at 36.0.4. The only workaround is by disabling OMTC (layers.offmainthreadcomposition.enabled) but i heard that the option to disable OMTC will be removed in the near future so that workaround will no longer be valid.

Tested on Windows 7 SP1. All Windows updates that is available at the time i write this is installed. VGA driver is using the latest stable driver from AMD which is Omega 14.12 driver.
Without disabling OMTC, what happens if you set gfx.direct2d.use1_1 to false?
(Reporter)

Comment 7

3 years ago
Unfortunately the problem still persists. The content area (if that's what it's actually called) still shows repainting problem. But the worst part is the address bar area (and the search bar).

I couldn't see what i was typing, so if i made a mistake typing something in that area, i have to select all and then retype it again without seeing what i was typing. The problem from what i can see is it is due to Firefox trying to autocomplete but because of repainting problem it is blocking the view. Of course pictures worth a thousand words so i have uploaded a gif showing the problem.

The gif was also taken from a clean profile and because of that the first word i typed is Mozilla because that words would already be there in bookmark to show you what the problem is. If it was on a live/real profile with hundreds of bookmarks/visited urls history/etc you can imagine almost every letters being typed would trigger the glitched autocomplete that made you unable to see what you just typed.

Gif Link: https://i.imgur.com/rgs6mFj.gif
Looking on attachment and description it's definitely a duplicate of bug #1067470.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1067470
(Assignee)

Comment 9

3 years ago
Bug 1067470 is a whole mix of problems. If this showed up in 37 it's worth keeping separate.

Aditya, can you try getting a regression window for this using mozregression?
http://mozilla.github.io/mozregression/
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(jmuizelaar) → needinfo?(adityaw321)
Resolution: DUPLICATE → ---
See Also: → bug 1067470
Severity: normal → major
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox-esr31: --- → unaffected
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 10

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #9)
> Bug 1067470 is a whole mix of problems. If this showed up in 37 it's worth
> keeping separate.
> 
> Aditya, can you try getting a regression window for this using mozregression?
> http://mozilla.github.io/mozregression/

I just finished the mozregression and here's the result. Hopefully this is what you're looking for.

25:09.33 LOG: MainThread Bisector INFO Narrowed inbound regression window from [0ea4d636, 24ba8274] (3 revisions) to [2a61df4e, 24ba8274] (2 revisions) (~1 steps left)
25:09.33 LOG: MainThread Bisector INFO Oh noes, no (more) inbound revisions :(
25:09.33 LOG: MainThread Bisector INFO Last good revision: 2a61df4eaa2d
25:09.34 LOG: MainThread Bisector INFO First bad revision: 24ba8274ed60
25:09.34 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a61df4eaa2d&tochange=24ba8274ed60
Flags: needinfo?(adityaw321)
(Assignee)

Updated

3 years ago
Flags: needinfo?(jmuizelaar)
(Assignee)

Comment 11

3 years ago
Do all of these builds show the problem? (You may need to wait for some of them to show up)

https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-a121a7a56ad5
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1432563618/
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-5da174860103
Flags: needinfo?(jmuizelaar)
(Reporter)

Comment 12

3 years ago
Yes, unfortunately all three builds showed the same problem. But on build a121a7a56ad5 it flickers/flashes a lot more compared to the other two builds.
(Assignee)

Updated

3 years ago
Assignee: nobody → jmuizelaar
Status: REOPENED → ASSIGNED
(Assignee)

Comment 13

3 years ago
Two more builds to test:
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-0a3c88b8051d/
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-3a70999c1394
(Reporter)

Comment 14

3 years ago
Build 0a3c88b8051d works great no display corruption/glitch at all. On the other hand, build 3a70999c1394 produce extreme flashes/flickers just like build a121a7a56ad5 from before.
(Reporter)

Comment 15

3 years ago
Forgot to put this on my previous comment. In case you're wondering how extreme the flashing/flickering are. I've uploaded it here http://a.pomf.se/wueqlr.mp4 (warning, flashing images).
(Assignee)

Comment 16

3 years ago
Here will be the next build to try:
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-19bc4fe771cb
(Assignee)

Comment 17

3 years ago
Two more builds:
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-02c7e6b65c88
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-3c79b0454d34
(Assignee)

Comment 18

3 years ago
All of the builds are up now.
Summary: Display corruption if hardware acceleration enabled on Firefox 37.0.1 → Display corruption if hardware acceleration enabled on Firefox 37.0.1, not just with D2D 1.1
(Reporter)

Comment 19

3 years ago
All three builds (02c7e6b65c88, 3c79b0454d34, and 19bc4fe771cb) works great no glitch/corruption at all :).
(Assignee)

Comment 20

3 years ago
And here's another build to try:
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-14d71149d1b9
(Reporter)

Comment 21

3 years ago
Unfortunately build 14d71149d1b9 produced a strange result. There's no graphics corruption/glitches as in it flickers/flashes this time it doesn't redraw/repaint the whole firefox area (not sure if this is the proper word for it) when switching between tabs or creating new tab or even opening options page.

A more detailed description of the problem:

1. Run the build
2. By default when starting clean profile there will be 2 tabs opened the Nightly first run and Nightly start page
3. Clicking on the tabs or switching the tabs using shortcut (CTRL+TAB NUM) resulted in no change at all in Firefox (i.e firefox not redraw/repaint?). But on the taskbar, i can confirm that the tab indeed switched because the title being displayed in taskbar changed but there's no change at all in firefox.
4. The same problem also appeared when opening new tab and opening options page.

The workaround to force firefox to redraw right away is simply by trying to close firefox (by default firefox prompt you if you try to close multiple tabs) and then canceling it.

Also if HW Acceleration turned off, the above problem gone.

I've uploaded a gif to better explain the problem https://imgur.com/hrbdbda . The same thing also happen when opening new tab, or even opening a website.
(Assignee)

Comment 22

3 years ago
How about this one:
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-aa0ca8b394fb
(Assignee)

Comment 23

3 years ago
Also, do you see the display corruption if you turn on the DWM/aero glass?
(Reporter)

Comment 24

3 years ago
The new build aa0ca8b394fb works great no display problem at all tested in both Classic and Aero. While the previous build (14d71149d1b9) has the same problem in both Classic and Aero.
(Reporter)

Comment 25

3 years ago
I tested the previous builds you posted here with Aero enabled and they produce exactly the same problem when i ran them on Classic mode. So i would say there's no difference between using Aero or not in this case.
(Assignee)

Comment 26

3 years ago
Do you see any graphics problems in Internet Explorer?
Flags: needinfo?(adityaw321)
(Assignee)

Comment 27

3 years ago
For the record, here's what IE 11 on Win7 uses for me:

pDevice = 0x6d245a8,
pDesc = [{BufferDesc = {Width = 1193,
                        Height = 648,
                        RefreshRate = {Numerator = 0, Denominator = 0},
                        Format = DXGI_FORMAT_B8G8R8A8_UNORM,
                        ScanlineOrdering = DXGI_MODE_SCANLINE_ORDER_UNSPECIFIED,
                        Scaling = DXGI_MODE_SCALING_UNSPECIFIED},
 SampleDesc = {Count = 1, Quality = 0},
 BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT,
 BufferCount = 1,
 OutputWindow = 0xc078e,
 Windowed = TRUE,
 SwapEffect = DXGI_SWAP_EFFECT_SEQUENTIAL,
 Flags = DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE}
(Assignee)

Comment 28

3 years ago
Here will be another build to try:
 https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-fd4f24b82488
(Reporter)

Comment 29

3 years ago
Unfortunately the new one (fd4f24b82488) produces graphics corruptions (flickers). As for IE11, it works fine no problem at all with hardware acceleration enabled also Chrome Beta, and Opera Next works fine too in case you're wondering.
Flags: needinfo?(adityaw321)
(Assignee)

Comment 30

3 years ago
I made a test program that should help us to iterate on this issue:
http://people.mozilla.org/~jmuizelaar/swap-chain.exe

This should start with a gray window. When you press a key it will paint blue. You can switch between red and blue by pressing the 'r' and 'b' keys respectively. Each time you press a key it will paint, but will decrease the area painted by one pixel from the right side of the window. Do you see any flickering with this test?
(Reporter)

Comment 31

3 years ago
I don't see flicker at all when running the test program. Btw, is there something changed between the last build (fd4f24b82488) and the one before that (aa0ca8b394fb)?. Because build aa0ca8b394fb worked fine and then on your last build the problem appears again.
(Assignee)

Comment 32

3 years ago
(In reply to Aditya from comment #31)
> I don't see flicker at all when running the test program. Btw, is there
> something changed between the last build (fd4f24b82488) and the one before
> that (aa0ca8b394fb)?. Because build aa0ca8b394fb worked fine and then on
> your last build the problem appears again.

Yes, I'm just flailing around a bit trying to see what special that might be causing things to fail for you.

Can you get a recording of the symptoms that happen with this build:

https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/jmuizelaar@mozilla.com-551d22ccfa72
(Reporter)

Comment 33

3 years ago
I recorded a video for build 551d22ccfa72 (warning flashing images)

https://d.maxfile.ro/mnpbmzdkkv.mp4

Also i just installed the beta driver from AMD (previously I'm using latest stable driver 14.12 before switched to beta) because from what i read the beta has optimizations for certain game that i just bought. Surprisingly build 551d22ccfa72 and even the previous build (fd4f24b82488) and also the one before that (aa0ca8b394fb) works fine or at least i haven't noticed any glitch so far. If you still need more testing just let me know.
(Assignee)

Comment 34

3 years ago
(In reply to Aditya from comment #33)
> I recorded a video for build 551d22ccfa72 (warning flashing images)
> 
> https://d.maxfile.ro/mnpbmzdkkv.mp4
> 
> Also i just installed the beta driver from AMD (previously I'm using latest
> stable driver 14.12 before switched to beta) because from what i read the
> beta has optimizations for certain game that i just bought. Surprisingly
> build 551d22ccfa72 and even the previous build (fd4f24b82488) and also the
> one before that (aa0ca8b394fb) works fine or at least i haven't noticed any
> glitch so far. If you still need more testing just let me know.

Thanks. The driver switch is pretty interesting. Would you mind trying some other older versions of the driver to see if it makes a difference?
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox-esr38: --- → affected
Keywords: regressionwindow-wanted
Aditya, were you ever able to follow up with Jeff's request in comment 34? Does this bug still reproduce for you?
status-firefox38: affected → ---
status-firefox38.0.5: affected → ---
status-firefox39: affected → ---
status-firefox40: affected → ---
status-firefox41: affected → ---
status-firefox42: affected → ---
status-firefox43: affected → ---
status-firefox-esr31: unaffected → ---
status-firefox-esr38: affected → ---
Flags: needinfo?(adityaw321)
(Reporter)

Comment 36

a year ago
Hello,

I'm so sorry, I didn't notice until today that this bug is still marked as unfixed because back then when I checked this bugzilla page (via browser for several days) I didn't see any response and so I thought maybe it was already marked as fixed. And because this email address is used for many mailing list, I often missed many things unless it was near the top of the mail in my Thunderbird (I saw notification about this today right at the top of my mail).

Actually I never experience this problem after switching display driver I mentioned before when I was using my old AMD 7730. But I've long switched from AMD to Nvidia (950 GTX), and on this new card I never experience any graphic issue that I described before (other than HW Video Decode not working and I have to clear the blacklist in the about:config to get it to work).

I'm sorry once again, and you can mark this as fixed.
You need to log in before you can comment on or make changes to this bug.