First file in style editor appears empty

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
3 years ago
2 months ago

People

(Reporter: ntim, Unassigned)

Tracking

({regression})

unspecified
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox38 unaffected, firefox39 fixed, firefox40 fixed)

Details

(Whiteboard: [polish-backlog])

(Reporter)

Description

3 years ago
I suspect bug 1147765 to be the culprit, but I have no concrete proof.
(Reporter)

Updated

3 years ago
Keywords: regression, regressionwindow-wanted
Sami, would you be able to take a look here, since you've done a lot of work on Style Editor recently?

I am able to reproduce this too, using mozilla.org as an example site.
Flags: needinfo?(sjakthol)

Comment 2

3 years ago
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=4d163f1939b5&tochange=01a988be408b
Blocks: 1147765
status-firefox38: --- → unaffected
status-firefox39: --- → affected
status-firefox40: --- → affected

Updated

3 years ago
Keywords: regressionwindow-wanted

Comment 3

3 years ago
This is indeed caused by my recent work and seem to be fixed once the second patch in bug 1148770 gets reviewed and landed.
Flags: needinfo?(sjakthol)

Updated

3 years ago
Depends on: 1148770
This appears to be fixed now by bug 1148770.  But bug 1148770 comment 89 suggests it make change or be undone.  Sami, is it safe to close this one now?
Flags: needinfo?(sjakthol)

Comment 5

3 years ago
It didn't fix the leak but it fixed this bug. It was also uplifted to Aurora as test-only change so this should be fine on Dev Edition too.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sjakthol)
Resolution: --- → FIXED
status-firefox39: affected → fixed
status-firefox40: affected → fixed
Priority: -- → P1
Whiteboard: [devedition-40] → [polish-backlog]

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.