Closed Bug 1151415 Opened 5 years ago Closed 3 years ago

[Linux] Focus rings are displayed in Reader View for the buttons available in the font panel

Categories

(Toolkit :: Reader Mode, defect, P3)

x86_64
Linux
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: avaida, Unassigned)

References

Details

(Whiteboard: [about-reader-ui])

Attachments

(2 files)

Note:
This is a follow-up issue filed for Bug 1135589.

Reproducible on:
* Beta 38.0b1-build1 (20150330154247)
* Aurora 39.0a2 (2015-04-05)
* Nightly 40.0a1 (2015-04-05)

Affected platform:
Ubuntu 14.04 (x64), Ubuntu 12.04 (x86)

Steps to reproduce:
1. Launch Firefox.
2. Go to: (e.g.) http://www.bbc.com/future/story/20150401-whats-the-most-we-can-remember
3. Click the "Enter Reader View" button from the Location Bar.
4. Click the "Type controls" button (Aa) → click the "Serif" font option.

Expected result: 
The "Serif" font option is applied in real time, without causing any UI issues.

Actual result:
A focus ring is placed on any of the buttons from inside the "Type controls" panel.
Priority: -- → P3
Component: General → Reader Mode
Product: Firefox → Toolkit
Whiteboard: [reader-ui] → [about-reader-ui]
Assignee: nobody → Rakhish1994
Attachment #8782346 - Flags: review?(gijskruitbosch+bugs)
It looks like this is a problem on linux generally: http://jsbin.com/xulojufipi/edit?html,css,output .

Clicking the button shows a focus outline on my linux VM, but not on my windows machine. It's not clear to me why this happens, and it's hard to investigate with the devtools because the focusring goes away when the window is unfocused. Setting outline: none !important; doesn't fix anything. This feels like a layout or widget issue. As a result, unassigning as this isn't a simple CSS bug, AFAICT.

Neil, any chance you know why there's a behaviour difference here compared to Windows and OS X?
Assignee: Rakhish1994 → nobody
Flags: needinfo?(enndeakin)
Version: 39 Branch → Trunk
Comment on attachment 8782346 [details]
Bug 1151415 - [Linux] Focus rings are displayed in Reader View for the buttons available in the font panel. r= Gijs.

https://reviewboard.mozilla.org/r/72542/#review70256

Clearing review because this patch does not remove the focus ring.
Attachment #8782346 - Flags: review?(gijskruitbosch+bugs)
Focus rings are always displayed when clicking controls on Linux. See https://wiki.mozilla.org/FocusBehaviour
Flags: needinfo?(enndeakin)
(In reply to Neil Deakin from comment #5)
> Focus rings are always displayed when clicking controls on Linux. See
> https://wiki.mozilla.org/FocusBehaviour

OK, then this is clearly just wontfix.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
(In reply to :Gijs Kruitbosch from comment #6)
> (In reply to Neil Deakin from comment #5)
> > Focus rings are always displayed when clicking controls on Linux. See
> > https://wiki.mozilla.org/FocusBehaviour
> 
> OK, then this is clearly just wontfix.

Err, I meant invalid. Oh well.
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.