Closed Bug 1151497 Opened 5 years ago Closed 5 years ago

Web site from RSS feed not rendered correctly (due to noscript tags) - tab part

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set

Tracking

(thunderbird38 affected, thunderbird39 affected, thunderbird40 fixed, thunderbird41 fixed, thunderbird_esr3839+ fixed)

RESOLVED FIXED
Thunderbird 41.0
Tracking Status
thunderbird38 --- affected
thunderbird39 --- affected
thunderbird40 --- fixed
thunderbird41 --- fixed
thunderbird_esr38 39+ fixed

People

(Reporter: Nomis101, Assigned: mkmelin)

References

Details

Attachments

(3 files)

Attached image screenshot of the issue
Bug 662907 fixed the noscript tag issue for rss feeds for the message pane, but not for tab. So, this is about fixing the issue in the tab. I found this while testing TB38b1, which will be the next ESR. So, it would be nice to get this fixed in TB38.

Steps to Reproduce:
1. Subscribe to feed http://www.heise.de/newsticker/heise-atom.xml
2. Open any post from that feed in a new tab.

Actual Results:  
Page from RSS feed isn't rendered properly when opened in TB. The top and right frame contain html code. 


I've included the screenshot from :JoeS1, but for me on OS X it looks the same. I see this issue too on feeds other than www.heise.de. It is fixed in the message pane and a workaround is described in this post: https://hitco.at/blog/mozilla-thunderbird-heise-rss-feed-korrekt-darstellen/
I'm quite sure that this was fixed in tab rendering in a previous bug.
But even with Total Message installed, I still see this bug.
Took the liberty to cc you alta88, your opinion is needed here.
Attached patch feedTab.patchSplinter Review
this patch works for messagepane loads in 3pane folder tab, 3pane message tab, and the standalone message window.  someone else will have to drive it from here.
Thanks for the patch. I have tested this one with a TB38 build and can confirm, that it will fix the issue in the message tab and the standalone window. But the feed looks different in the message pane.
(In reply to Nomis101 from comment #3)
> But the feed looks different in the message pane.

Does that mean that you think that the patch is a bad idea?

I tried to reproduce this problem and could not. Is it still there?
Yes, it's still there, but only some feeds, and you must view as a webpage
http://www.heise.de/newsticker/heise-atom.xml demonstrates the problem.
It's a definite improvement, so we should take the patch IMO
I've looked at posts from http://www.heise.de/newsticker/heise-atom.xml in a tab, I see the full web page, looks fine. So I am not reproducing.
(In reply to Kent James (:rkent) from comment #6)
> I've looked at posts from http://www.heise.de/newsticker/heise-atom.xml in a
> tab, I see the full web page, looks fine. So I am not reproducing.

Neither am I, as i am 73 years old. But as for the bug, I see it every time reliably.
I also still see it (in TB 38b3).


(In reply to Kent James (:rkent) from comment #4)
> (In reply to Nomis101 from comment #3)
> > But the feed looks different in the message pane.
> 
> Does that mean that you think that the patch is a bad idea?
No, sorry, I was wrong. I tested today again with a build with and without this patch. And the patch works fine. The feed looks the same in the message pane in both builds (so, I think it should look like this). Therefore, I think the patch is a good idea. Is it OK if I set it for review?
Yes, set for review. I was hoping to help move this forward but I cannot reproduce which limits me.
Attachment #8590016 - Flags: review?(mkmelin+mozilla)
Magnus, this is currently set as a Thunderbird 38 blocker, but I cannot reproduce this. Can you attempt the review? Can you reproduce this?
We are not making progress on this, and it is not critical enough to block release.
Comment on attachment 8590016 [details] [diff] [review]
feedTab.patch

Review of attachment 8590016 [details] [diff] [review]:
-----------------------------------------------------------------

Yes this looks fine. r=mkmelin
Attachment #8590016 - Flags: review?(mkmelin+mozilla) → review+
mozmill test to prove it works
Assignee: nobody → mkmelin+mozilla
Attachment #8622001 - Flags: review?(alta88)
Try shows no new errors.
Comment on attachment 8622001 [details] [diff] [review]
feedtab-tests.patch

Review of attachment 8622001 [details] [diff] [review]:
-----------------------------------------------------------------

looks good.  this bug manifests only if javascript.enabled is true.  although that is the default, and it's not honored by content policy when setting javascript on the docShell, it matters elsewhere.  perhaps it might be useful to set it in the test explicitly for future reference.
Attachment #8622001 - Flags: review?(alta88) → review+
https://hg.mozilla.org/comm-central/rev/e769c32b3fb7
https://hg.mozilla.org/comm-central/rev/c2fb477b2e17
-> FIXED
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 41.0
Comment on attachment 8590016 [details] [diff] [review]
feedTab.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: <noscript> content shown in tabbed feed content

We should uplift this after some trunk baking.
Attachment #8590016 - Flags: approval-comm-esr38?
Attachment #8590016 - Flags: approval-comm-aurora?
Attachment #8622001 - Flags: approval-comm-esr38?
Attachment #8622001 - Flags: approval-comm-aurora?
Attachment #8590016 - Flags: approval-comm-aurora? → approval-comm-aurora+
Attachment #8622001 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8622001 [details] [diff] [review]
feedtab-tests.patch

http://hg.mozilla.org/releases/comm-esr38/rev/c29b2def0b48
Attachment #8622001 - Flags: approval-comm-esr38? → approval-comm-esr38+
Comment on attachment 8590016 [details] [diff] [review]
feedTab.patch

http://hg.mozilla.org/releases/comm-esr38/rev/e7d0e7c36518
Attachment #8590016 - Flags: approval-comm-esr38? → approval-comm-esr38+
You need to log in before you can comment on or make changes to this bug.