ExtendableEvent.waitUntil should log rejected Promises

RESOLVED DUPLICATE of bug 1150959

Status

()

Core
DOM: Workers
RESOLVED DUPLICATE of bug 1150959
3 years ago
3 years ago

People

(Reporter: nsm, Assigned: nsm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

Right now if installation/activation fail due to Promise rejection, there is no way for the webdev to see that in an obvious way.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150959
Created attachment 8589951 [details] [diff] [review]
Log rejected Promise error message to browser console

The result.Failed() case can be removed since we return early instead of just creating a rejected Promise.
This is because just creating a rejected promise due to an error in the event handler will lead to two logs in the console, one from the error itself, and one from the intentional promise rejected. I wanted to avoid that.
Attachment #8589951 - Flags: review?(amarchesini)
Assignee: nobody → nsm.nikhil
Comment on attachment 8589951 [details] [diff] [review]
Log rejected Promise error message to browser console

attached to wrong bug
Attachment #8589951 - Attachment is obsolete: true
Attachment #8589951 - Flags: review?(amarchesini)
You need to log in before you can comment on or make changes to this bug.