indexedDB::::CancelableRunnableWrapper::Cancel releases CCed objects after worker CC is shut down

RESOLVED FIXED in Firefox 40

Status

()

Core
DOM: IndexedDB
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mccr8, Assigned: Ben Turner (not reading bugmail, use the needinfo flag!))

Tracking

(Blocks: 1 bug)

Trunk
mozilla40
Points:
---

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
I came across a few of these.  It looks like there was an IDB runnable that is releasing a DETH, but it is late enough in shutdown that the CC is gone.

https://crash-stats.mozilla.com/report/index/d7968201-b10e-4c9d-a1a1-567cd2150401#allthreads
https://crash-stats.mozilla.com/report/index/65738f58-194c-4bf6-9b9b-f19ac2150401
https://crash-stats.mozilla.com/report/index/5192ba6f-1389-4daf-97a0-8fabe2150401
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Created attachment 8588814 [details] [diff] [review]
Patch, v1

I think this is all we need to do.
Attachment #8588814 - Flags: review?(khuey)
Created attachment 8588816 [details] [diff] [review]
Cleanup, v1

This isn't stcitly needed for this bug but while I was looking here I noticed that the runtime-private stuff has grown a few too many warts over the years. This cleans it up a little. No changes to behavior.

And the IDBFactory change was a silly assertion failure fix.
Attachment #8588816 - Flags: review?(khuey)
Attachment #8588814 - Flags: review?(khuey) → review+
Attachment #8588816 - Flags: review?(khuey) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/736c8f8f8c9b
https://hg.mozilla.org/integration/mozilla-inbound/rev/d225c07cf671
https://hg.mozilla.org/integration/mozilla-inbound/rev/40cbdbbf2a26
Duplicate of this bug: 1152174
https://hg.mozilla.org/mozilla-central/rev/736c8f8f8c9b
https://hg.mozilla.org/mozilla-central/rev/d225c07cf671
https://hg.mozilla.org/mozilla-central/rev/40cbdbbf2a26
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.