Closed Bug 1151665 Opened 5 years ago Closed 5 years ago

[EME] Add missing ^headers^ files to tests

Categories

(Core :: Audio/Video, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox38 --- ?
firefox40 --- fixed

People

(Reporter: gerald, Assigned: gerald)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Some EME tests are missing ^headers^ files matching mp4 and m4s fragments, which could cause cache issues with the test server.
It might be the cause of some intermittent test failures (e.g. bug 1120741) as the server would sometimes feed the wrong contents.
Updated make-headers.sh to generate ^headers^ files for m4s fragments.
Attachment #8588873 - Flags: review?(edwin)
Added missing ^headers^ for EME tests.
Attachment #8588874 - Flags: review?(edwin)
sorry had to back this out in https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=5e4ea3189ff7 seems one of this changes caused frequent test failures like:

https://treeherder.mozilla.org/logviewer.html#?job_id=8536619&repo=mozilla-inbound
Flags: needinfo?(gsquelart)
I don't believe these ^header^ files are the cause of already-known intermittent failures, in fact they could only help remove some of them.
Flags: needinfo?(gsquelart)
It seems unlikely that this change cause this orange spike as the changes here work around a bug in Firefox's network cache and so should actually make our orange rate go *down*.

Also, I only see one failure logged in bug 1148844 in the time period where this changeset was landed. Where are the other failures logged? Why do failures of test_eme_persistent_sessions not appear in bug 1148844?

Are the failures only on linux-e10s-m3? Without failures logged it's impossible for us to tell. If it's an e10s only failure, we should just disable the test in e10s, as e10s EME support was only enabled over the weekend.
Flags: needinfo?(cbook)
Apologies to cbook and Tomcat, it looks like adding these ^headers^ does exacerbate test_eme_persistent_sessions failures:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ff7fcce15843
Very strange! Might be a timing issue?

Anyway later patches help bring these issues down again:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=48477eca32d6

So I will reorder patches so that they hopefully make more sense (while not hiding real code issues)...
No longer blocks: 1151693
Gerald, cpearce: should we uplift these test changes to Beta 38?
Flags: needinfo?(cpearce)
Priority: -- → P2
My apologies to tomcat as well.
Flags: needinfo?(cbook)
(In reply to Chris Peterson [:cpeterson] from comment #9)
> Gerald, cpearce: should we uplift these test changes to Beta 38?

This will probably just be a test-only change, so I think at this stage we can assume it doesn't need uplifting.
Flags: needinfo?(cpearce)
https://hg.mozilla.org/mozilla-central/rev/d0828107f887
https://hg.mozilla.org/mozilla-central/rev/b385aa775aef
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.