[RTL][Dialer]The ellipsis shown at wrong side of text when user cheks info of a call log.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Sue, Assigned: thills)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [planned-sprint c=1][2.2-nexus-5-l])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8589002 [details]
ellipsis_when_long_press_a_call_log.png

[1.Description]:
[RTL][v2.2 & v3.0][Dialer]The ellipsis shown at wrong side of text with the long LTR name when long press a call log.
See attachment:ellipsis_when_long_press_a_call_log.png

[2.Testing Steps]: 
1. Set your phone language to Arabic and launch Dialer. 
2. Tap call log tab. 
3. Long tap one call log. 
4. Observe the action page.
5. Select call information. 
6. Observe the page of call information. 

[3.Expected Result]: 
4&6. If the contacts with long LTR name, the ellipsis should be displayed at right side of the text, if the contacts with long RTL name, the ellipsis should be displayed at left side of the text. 

[4.Actual Result]: 
4&6. The ellipsis shown in left side of text when the contacts with long LTR name.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
15433
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
The fix has landed in master just after the build you tested against. Duping this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150953
Oops, wrong RTL bug. This is not a dupe.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Priority: -- → P2
(Assignee)

Updated

3 years ago
Assignee: nobody → thills
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F [planned-sprint c=1]
Target Milestone: --- → 2.2 S10 (17apr)
Created attachment 8590267 [details] [review]
[gaia] tamarahills:bugfix/1151770-ellipsis-call-log-info-header > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8590267 - Flags: review?(felash)
Attachment #8590267 - Flags: review?(drs)
Attachment #8590267 - Flags: review?(drs) → review+
Your solution seems simpler but... it breaks things in at least the SMS app. I'm sure we could fix it but I guess you'll want this in v2.2 and I think it's too late in v2.2 to break this.

To see what break, have a contact with a picture, a thread for this contact, and press the thread header. You'll see the picture is not well located. I'm sure this is a issue in SMS that we can fix but I don't really want to fix this with the 2.2 urgency.

I also see issues with translated headers, they're not correctly aligned with this change. This could be an issue of "Runtime Mirrored English" though. See for example the title when tapping the top right "..." button in a SMS thread. You'll see that "Message" is aligned to the left (despite using "text-align: start", which means that "dir=auto" computes to "dir=ltr"... that's why I say it could be an issue with the Runtime Mirrored English).


Moreover you don't fix the issue in the Call Log Information page.


In the SMS app we did things like [1] or [2] (in the SMS app we also have more complex cases where we want to display the contact picture if available).

I think you should use <bdi class="ellipsis-dir-fix"> like we did in SMS everywhere (search for ellipsis-dir-fix in [2] to have an idea).
I suggest to do the same for your OptionMenu header.

Our ellipsis-dir-fix class definition is at [3] if you want to steal it. Maybe you have something similar in Dialer already.

[1] https://github.com/mozilla-b2g/gaia/blob/ca692311bddbd54b2fc7a2d507a68b2d0dd487c2/apps/sms/js/thread_ui.js#L2791-L2795
[2] https://github.com/mozilla-b2g/gaia/blob/ca692311bddbd54b2fc7a2d507a68b2d0dd487c2/apps/sms/index.html#L608-L612
[3] https://github.com/mozilla-b2g/gaia/blob/ca692311bddbd54b2fc7a2d507a68b2d0dd487c2/apps/sms/style/sms.css#L1062-L1070

Tell me what you think.
(Assignee)

Comment 5

3 years ago
Comment on attachment 8590267 [details] [review]
[gaia] tamarahills:bugfix/1151770-ellipsis-call-log-info-header > mozilla-b2g:master

Thanks Julien for catching this!

I'm going to give this a try.  I'll reset the review flag once I have an update.

Thanks,
-tamara
Attachment #8590267 - Flags: review?(felash)
Also looks like bug 883884 is now 2.2+... so maybe you can prepare a patch but not merge it until we see bug 883884 is resolved or not?
(Assignee)

Comment 7

3 years ago
Comment on attachment 8590267 [details] [review]
[gaia] tamarahills:bugfix/1151770-ellipsis-call-log-info-header > mozilla-b2g:master

Hi Doug,

This has changed significantly since the first patch, so I'm resetting the review flag.

Thanks,

-tamara
Attachment #8590267 - Flags: review+ → review?(drs)
Comment on attachment 8590267 [details] [review]
[gaia] tamarahills:bugfix/1151770-ellipsis-call-log-info-header > mozilla-b2g:master

Looks good to me. Let's ask Julien to review again, though.
Attachment #8590267 - Flags: review?(felash)
Attachment #8590267 - Flags: review?(drs)
Attachment #8590267 - Flags: review+
Comment on attachment 8590267 [details] [review]
[gaia] tamarahills:bugfix/1151770-ellipsis-call-log-info-header > mozilla-b2g:master

I haven't _really_ tried the cases with various values on the phone, but the changes look about right.

I only added a comment about the "width" value we use in SMS, but maybe you don't need this in Dialer.
Attachment #8590267 - Flags: review?(felash)
(Reporter)

Comment 10

3 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15433/
Flags: in-moztrap+
(Reporter)

Comment 11

3 years ago
Hi Tamara,
This issue can be reproduced on latest build of Flame 2.2&3.0 and Nexus 5 2.2&3.0 by STRs in comment 0. Could you please help with this issue? Thanks :)

Device information:
Flame 2.2 Build ID: 20150526162504
Flame 3.0 Build ID: 20150526160204
Nexus5 2.2 Build ID: 20150526162504
Nexus5 3.0 Build ID: 20150526160204
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Flags: needinfo?(thills)
Whiteboard: MGSEI-RTL-3F [planned-sprint c=1] → MGSEI-RTL-3F [planned-sprint c=1][2.2-nexus-5-l]
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F [planned-sprint c=1][2.2-nexus-5-l] → [planned-sprint c=1][2.2-nexus-5-l]
This issue can be reproduced on latest build of AriesKK_V2.5.
Rate:5/5
Device:AriesKK_V2.5
Build ID               20150811150203
Gaia Revision          2d7f369fd923b6df3b00d76844c413c1202c04ba
Gaia Date              2015-08-11 09:58:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/38c1ea9ccae31700630f1fe0d651e94c0c5b9e1d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.182056
Firmware Date          Tue Aug 11 18:21:06 EDT 2015
Bootloader             L1TC000118D0
Blocks: 1181927
Created attachment 8646725 [details]
AriesKK_V2.5.png
Created attachment 8680442 [details]
ellipsis_call log_v2.5.png

This issue cannot be reproduced on latest FlameKK&AriesKK v2.5 build by the same STR in comment 0.
Actual result:Long press the call log that the contact with the long LTR name, the ellipsis is displayed at right side of the name in the select view.
See attachment:ellipsis_call log_v2.5.png.
Reproducing rate:0/10

Device: FlameKK v2.5 build (512mb)
Build ID               20151028150209
Gaia Revision          2e89362de40a6c9c36525d36317fa1ae8e67e143
Gaia Date              2015-10-28 04:56:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fc706d376f0658e560a59c3dd520437b18e8c4a4
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151028.182746
Firmware Date          Wed Oct 28 18:27:57 EDT 2015
Firmware Date           v18D v4
Bootloader             L1TC000118D0

Device: AriesKK v2.5 build
Build ID               20151029010303
Gaia Revision          75f2236d36cc9f9c02d3596fae3de014007cfd82
Gaia Date              2015-10-28 17:02:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1e700005a0ddf2b17803213e1f3f8d78a7a618b8
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151029.002011
Firmware Date          Thu Oct 29 00:20:19 UTC 2015
Bootloader             s1
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(thills)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.