[RTL][Dialer]The "+" symbol is shown at wrong side at callscreen when we MO a contact whose number has "+" symbol.

VERIFIED DUPLICATE of bug 1150953

Status

defect
VERIFIED DUPLICATE of bug 1150953
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master unaffected)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
Posted image callscreen.png
[1.Description]:
[RTL][v2.2&v3.0][Dialer]When we MO a call to a contact whose number has "+" symbol, like "+86123456", the "+" symbol is shown at wrong side at callscreen.
See attachment:callscreen.png

[2.Testing Steps]: 
1. Set your phone language to Arabic. 
2. New some contacts whose phone number has "+861" in contacts. (such as "+86123456")
3. Launch Dialer and tap the dial Pad to input "861". 
4. Tap the matched number.

[3.Expected Result]: 
4. The "+" symbol should be shown at left side of number.

[4.Actual Result]: 
4. The "+" symbol is shown at the right side of number.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.194015
Firmware Date          Mon Apr  6 19:40:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
16006
Reporter

Comment 1

4 years ago
Update the description in comment 0, this issue do not exist on latest build of Flame 3.0
Rate:0/5
QA Whiteboard: [rtl-impact]
The fix has been made in bug 1150953
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1150953
QA Whiteboard: [rtl-impact] → [rtl-impact]MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F
According to comment 36 in bug 1150953 and my own verification, the problem is fixed now. 
Mark as VERIFIED DUPLICATE.

Device information:
Flame v2.2 Build ID: 20150721162504
N5 v2.2 Build ID: 20150721002506
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact]MGSEI-RTL-3F → [rtl-impact]MGSEI-RTL-3F[MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.