The content of the Firefox menu is missing in Firefox 38 under Mac OS X 10.10

RESOLVED DUPLICATE of bug 1151345

Status

()

RESOLVED DUPLICATE of bug 1151345
3 years ago
3 years ago

People

(Reporter: Vincent.Boudry, Unassigned)

Tracking

38 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8589056 [details]
Capture d’écran 2015-04-07 à 14.11.08.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150330154247

Steps to reproduce:

Ckicked on "Firefox menu"


Actual results:

Only the "Quit Cmd-Q" item appears


Expected results:

have the full Firefox menu starting with "About Firefox"...

Comment 1

3 years ago
Is it reproducible?

If yes, in safe mode?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

With a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(Vincent.Boudry)
(Reporter)

Comment 2

3 years ago
Yes I have tried both.
Flags: needinfo?(Vincent.Boudry)

Comment 3

3 years ago
Is FF39 only affected? Did you test with FF37 or lower?
Summary: The content of the firefox menu is missing in M38 under OSX → The content of the Firefox menu is missing in Firefox 38 under Mac OS X 10.10
Component: Untriaged → Menus
(Reporter)

Comment 4

3 years ago
Everything was fine prior to FF38 (used it to update).

Comment 5

3 years ago
(In reply to Boudry Vincent from comment #4)
> Everything was fine prior to FF38 (used it to update).

So it has pobably regressed, and we need a regression range.
As you're able to reproduce it, could you download and run the tool mozregression to find a possible regression range, please.
See http://mozilla.github.io/mozregression/ for details about install and usage.

As FF37 (or 36) worked fine, run "mozregression --good-release 37" and copy here the pushlog (no need to bisect more).
Flags: needinfo?(Vincent.Boudry)
Keywords: regressionwindow-wanted

Comment 6

3 years ago
Created attachment 8605225 [details]
Firefox38 Mac No Preferences

Comment 7

3 years ago
Created attachment 8605226 [details]
mozregression Mac good menu

Comment 8

3 years ago
I too am having this issue on Mac 10.10 with Firefox 38.
I ran `mozregression --good-release 37` and it gave it this: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e861531c04fa&tochange=c6a3db6682e0

None of the builds that the regression tool opened seemed to have the menu issue where only Quit shows up.

Is there anything else I should test to help narrow this down?

Comment 9

3 years ago
I just opened the menu again in Firefox 38, and now the correct menu items are showing... No idea why it's working now.

FWIW I tried the steps you previously posted, and they did not help:
* Opening in safe mode
* Opening with a fresh profile

When the menu wasn't displaying all the items, the Mac keyboard shortcuts also did not work, at least not CMD+H to hide the application. Now that the menu is showing all the items, CMD+H works.

I've tried to get the menu to misbehave again, but can't reproduce the issue.
I just opened Firefox 38 RC build 3 under Mac OS X 10.10.4 with existing and new profiles and couldn't reproduce the issue.
(Reporter)

Comment 11

3 years ago
I still have the issue, after the update of today (38.0.5).
I forgot yo report that I cannot get the prerefences by shortcut (Cmd-,).
So it seems that all the Firefox-menu shortcut are off.
Flags: needinfo?(Vincent.Boudry)

Comment 12

3 years ago
(In reply to jammnrose from comment #8)
> I too am having this issue on Mac 10.10 with Firefox 38.
> I ran `mozregression --good-release 37` and it gave it this:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=e861531c04fa&tochange=c6a3db6682e0
> 
> None of the builds that the regression tool opened seemed to have the menu
> issue where only Quit shows up.
> 
> Is there anything else I should test to help narrow this down?

This changelog is probably wrong, especially if you didn't hit any bad builds.

Updated

3 years ago
Duplicate of this bug: 1172002

Comment 14

3 years ago
dupe of bug 1151345?

Comment 15

3 years ago
Vincent, could you download Nightly to confirm it's fixed on your side, please.
https://nightly.mozilla.org/
Flags: needinfo?(Vincent.Boudry)
(Reporter)

Comment 16

3 years ago
Confirmed: in Nightly the menu is back.
Flags: needinfo?(Vincent.Boudry)

Comment 17

3 years ago
Ty for confiming.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151345
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.