keyboard does not disappear after user starts to scroll

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: daleharvey, Assigned: daleharvey)

Tracking

unspecified
2.2 S10 (17apr)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Assignee)

Updated

4 years ago
Component: Gaia::Feedback → Gaia::Search
(Assignee)

Comment 1

4 years ago
Carrying the r+ from the previous patch, this is exactly what was r+'d, made a minor nit for the original check in
Assignee: nobody → dale
Attachment #8589082 - Flags: review+
(Assignee)

Comment 2

4 years ago
Landed in https://github.com/mozilla-b2g/gaia/commit/f2c980badda69ed30a00d95e42c9503b50a07374
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

4 years ago
Comment on attachment 8589082 [details] [diff] [review]
0001-Bug-1151822-Follow-up-to-hide-keyboard-on-search-app.patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): https://bugzilla.mozilla.org/show_bug.cgi?id=1149435, was a blocking bug that landed with an incorrect fix
[User impact] if declined: Poor user experience in search app
[Testing completed]: Manual verification and unit tests added
[Risk to taking this patch] (and alternatives if risky):Little risk
[String changes made]:
Attachment #8589082 - Flags: approval-gaia-v2.2?
blocking-b2g: --- → 2.2+
Whiteboard: [systemsfe]
Target Milestone: --- → 2.2 S10 (17apr)
Blocks: 1149435
Keywords: verifyme
Attachment #8589082 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on latest Nightly Flame v2.2&3.0.
See attachment: verified_v2.2&3.0.MP4
Reproduce rate: 0/5

STR:
1. Tap rocketbar at Homescreen and input something.
2. After result list is shown, start to scroll down.
**keyboard disappears as expected.


Device: Flame 2.2 build(Pass)
Build ID               20150408162503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9ab8a3ae0fc3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150408.200144
Firmware Date          Wed Apr  8 20:01:56 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Pass)
Build ID               20150408160203
Gaia Revision          a290b11627ec2b7c25980f5687a98da86641cfe4
Gaia Date              2015-04-08 08:26:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c92a7df87c9
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150408.194323
Firmware Date          Wed Apr  8 19:43:34 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.