[Music][Slider/Scrubber] The slider and song time will become frozen when trying to tap multiple buttons at once

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: dharris, Unassigned)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)
polish, regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(4 attachments)

Created attachment 8589235 [details]
Music Slider Logcat

Description:
If the user tries to tap the back button, or the play/pause button while they are pressing on the slider, all of the UI in the music app will freeze, but the music will contine to play, and buttons will still function. It should be noted that I have gotten this by sliding the slider around and having my finger slide over the star rating, or play/pause button. The "tap the back button ~6 times" step is just the easiest way to reproduce.


Repro Steps:
1) Update a Flame to 20150407010204
2) Open Music app
3) Select a song
4) Tap and hold the music scrubber
5) While holding the scrubber, tap the back or pause button ~6 times quickly
6) Let go of the scrubber


Actual:
Scrubber and music time will be frozen, but music will contine to play


Expected:
Nothing is frozen. Everything plays as expected


Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150407010204
Gaia: c710bac533b76635161315bf907d004e000549cb
Gecko: ab0490972e1e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 7/10
See attached: Logcat, Video - https://youtu.be/ZmJ8d-kiK48
This issue DOES occur on Flame 2.2, and Flame 2.1

Scrubber and music time will be frozen, but music will contine to play

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150406002503
Gaia: a6351e1197d54f8624523c2db9ba1418f2aa046f
Gecko: c3335a5d3063
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150403001204
Gaia: 4e7d880defb83c25b49462479c02b3e64d21f421
Gecko: e76f5e7a264d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

=======================================================================================================

This issue does NOT occur on Flame 2.0

Nothing is frozen. Everything plays as expected

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150407000203
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: a782e16d271f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.  Visual Regression that can be recovered by tapping the play button or the slider.  Also music continues to play.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(npark)
The multitouch is technically not supported by the Music app UI, but it's interesting to see the UI freezing, ni?ing Jim in case this points to a more serious underlying issue.
Flags: needinfo?(npark) → needinfo?(squibblyflabbetydoo)

Comment 4

4 years ago
I feel like we have a similar bug on file about this, but I can't find it...
Flags: needinfo?(squibblyflabbetydoo)

Comment 5

4 years ago
Oops, hit enter too early.

This is probably due to some weirdness surrounding how touch events work. Probably, the scrubber never gets the touchend event, and things get confused.

Updated

4 years ago
Keywords: polish

Comment 6

3 years ago
I don't see this in the NGA version of the app anymore. Could you take a look to see if it's fixed now?
Keywords: qawanted

Comment 7

3 years ago
This DOES still repro on Aries 2.5, Flame 2.5 and Flame 2.2
Result: Scrubber and music time will be frozen, but music will continue to play.

Environmental Variables:
Device: Aries 2.5 Kk
BuildID: 20151002110438
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (512mb)
Build ID: 20151002030232
Gaia: 9a682cb7bc8b7fde624a9b2b3c2d64415a08b04b
Gecko: 5f16c6c2b969f70e8da10ee34853246d593af412
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
BuildID: 20151002032503
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 2ab95b3d02a7
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
I *think* I reproduced this? I dunno. I was able to get to a blank screen by scrubbing the slider and hammering on the back button. Taking this to try and improve robustness of the "back" button.
Assignee: nobody → jdarcangelo
Created attachment 8669848 [details] [review]
[gaia] justindarc:bug1151986 > mozilla-b2g:master
Attachment #8669848 - Flags: review?(squibblyflabbetydoo)

Updated

3 years ago
Attachment #8669848 - Flags: review?(squibblyflabbetydoo) → review+
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/3337e2b5a9f5acc8eb7c771ca165ec8b2d435264
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment hidden (obsolete)
Created attachment 8674764 [details]
logcat_1530.txt

Hi Justin,

This bug has verified as fail on latest build of FlameKK v2.5 and Aries KK v2.5 by the STR in comment 0. 

While holding the scrubber, tap the back or pause button more than~6 times quickly, you can reproduce this issue.

Could you help to take a look? Thank you very much.

----------------------------------------------------------------------------------
Actual results: Scrubber and music time is frozen, but music can contine to play.
See attachments: FlameKK_v2.5.3gp & logcat_1530.txt
Reproduce rate: 8/20

Device: Flame KK 2.5 (fail)
Build ID               20151015150343
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151015.183044
Firmware Date          Thu Oct 15 18:30:54 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (fail)
Build ID               20151015193337
Gaia Revision          8ea9029190af2ffeb04dcd97b323738125e31a0e
Gaia Date              2015-10-15 14:30:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d374d16cbb251c9dac5af69f8e186e821ce82fe2
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151015.185317
Firmware Date          Thu Oct 15 18:53:25 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Yep. After following the STR in comment 12, I can still reproduce. Re-opening.
Status: RESOLVED → REOPENED
Flags: needinfo?(jdarcangelo)
Resolution: FIXED → ---
Not working on this. Unassigning myself.
Assignee: jdarcangelo → nobody

Comment 15

8 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.