Firefox Hello audio on Flame v2.2 is not routed to the loud speaker

VERIFIED FIXED in Firefox 40

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: diego, Assigned: alwu)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 verified, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 815031])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
The incoming sound during an audio/video session is instead routed to the phone's earpiece. You can hear sound if you put the phone up to your ear like a regular phone call.

This is a regression from v2.1 were it sound came through the loud speaker.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
(Reporter)

Updated

4 years ago
Whiteboard: [CR 815031]
Whiteboard: [CR 815031] → [caf priority: p2][CR 815031]
(Reporter)

Updated

4 years ago
Summary: Firefox Hello audio on Flame v2.2 is not routed to the speaker → Firefox Hello audio on Flame v2.2 is not routed to the loud speaker
Steven, can you take a look? Thanks.
Flags: needinfo?(slee)

Comment 2

4 years ago
Hi Alastor,

Please check this bug, thanks.
Flags: needinfo?(slee) → needinfo?(alwu)
(Assignee)

Comment 3

4 years ago
Ok, I will check it.
Assignee: nobody → alwu
Flags: needinfo?(alwu)
triage: major regression
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 5

4 years ago
[Root cause]
Didn't check the call state, we used the "Media" usage to switch the speaker. 

[Solution]
Since there was the voice-call audio track on the audio output, the routing would be set to receiver. The only way to change the routing to speaker is to use the "Communication" usage instead of "Media".

---

If the try-server result is ok, I will ask for the review.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ebdc386f0a0a
(Reporter)

Comment 6

4 years ago
Comment on attachment 8590125 [details] [diff] [review]
Use the communication usage to switch the routing

Review of attachment 8590125 [details] [diff] [review]:
-----------------------------------------------------------------

The patch works for me, thanks!
Attachment #8590125 - Flags: feedback+
(Reporter)

Updated

4 years ago
(Assignee)

Comment 7

4 years ago
Comment on attachment 8590125 [details] [diff] [review]
Use the communication usage to switch the routing

Hi, Baku,
Could you help me review this patch?
Very appreciate :)
Attachment #8590125 - Flags: review?(amarchesini)
Attachment #8590125 - Flags: review?(amarchesini) → review+
(Assignee)

Comment 8

4 years ago
Attachment #8590125 - Attachment is obsolete: true
Attachment #8590692 - Flags: review+
(Assignee)

Comment 9

4 years ago
Comment on attachment 8590692 [details] [diff] [review]
Use the communication usage to switch the routing. r=baku.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Regression bug
User impact if declined: Can't hear sound from the speaker during the VOIP call
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Attachment #8590692 - Flags: approval-mozilla-b2g37?
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/8fa8ef7b1d47
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S10 (17apr)
Attachment #8590692 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
This bug has been verified as "pass" on latest nightly build of Flame v2.2.

STR:
1. Install Hello app and sign in a firefox account.
2. Make a audio/video call and other device receives this call.
3. Listen to the sound.

Actual results: The sound is routed to the loud speaker.
See attachment: verified_Flame_v2.2.3gp
Reproduce rate: 0/10


Device: Flame v2.2 (Verified) 
Build ID               20150719002503
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2d1f1f55803
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150719.041302
Firmware Date          Sun Jul 19 04:13:13 EDT 2015
Bootloader             L1TC000118D0


Note: 
I can't verify this bug on latest Flame master, because it can't login the firefox account in Loop app (blocked by Bug 1168173).
QA Whiteboard: [MGSEI-Triage+]
According to "https://bugzilla.mozilla.org/show_bug.cgi?id=1168173#c8", it is 'WON'T FIX' since we're not supporting the Hello Firefox OS application anymore, so change status to "verified".
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.