Closed Bug 1152007 Opened 5 years ago Closed 4 years ago

[RTL][Dialer] Increased spacing on "Call ended" + call time strings when ending a conference call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

Details

(Keywords: polish, Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Attached image CallEndedENG.png
Description:
When ending a conference call, "Call Ended" and the call time are displayed on the callscreen. In RTL mode, the spacing is increased too much, so the "Call Ended" string is too close to the bottom edge, and the call time is not displayed.

Pre-requisite: Have at least 2 contacts with phone numbers.

Repro Steps:
1) Update a Flame to 20150407010204.
2) Set the device language in Arabic under Settings > Language.
3) Receive an incoming call from a contact, and answer the call.
4) While being on the call, receive a second incoming call from another contact, and answer the call.
5) Merge the calls to start the conference call.
6) Hang up one of the incoming calls.
7) Observe the "Call Ended" string on the callscreen.

Actual:
"Call Ended" string is too close to the edge, and the call time is not showing.

Expected:
"Call Ended" and call time are displayed properly.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150407010204
Gaia: c710bac533b76635161315bf907d004e000549cb
Gecko: ab0490972e1e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 5/5
See attached: screenshot
This issue also reproduces on Flame 2.2.

Result: "Call Ended" string is too close to the edge, and the call time is not showing.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
BuildID: 20150407002501
Gaia: 5e09637414269728f6f1bc0152d0160f3b6b380e
Gecko: 245f37f44017
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [[QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [[QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Blocks: dialer-rtl
Priority: -- → P3
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Hi William,
This issue can be reproduced on latest Flame 2.2&3.0,"Call Ended" string is too close to the edge, and the call time is not showing, could you have someone to help with this bug? Many thanks!

Note:This issue cannot be reproduced on latest Nexus5 2.2&3.0 build.

Device information:
Flame 2.2 Build ID:20150527002504
Flame 3.0 Build ID:20150527160204
Nexus5 2.2 Build ID:20150527002504
Nexus5_3.0 Build ID:20150527160204
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Flags: needinfo?(whsu)
I would like to change the priority to P2 since the "call time" is hidden and "Call Ended" UI is broken.
Flags: needinfo?(whsu)
Keywords: polish
Priority: P3 → P2
This issue doesn't exist on lastest build of Aries KK_V2.5.
Rate:0/5
Device:Aries KK_V2.5[Affected]
Build ID               20150806203229
Gaia Revision          7f387f859d48f9ad0761637c78447dc524747738
Gaia Date              2015-08-06 15:21:13
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/03e3d77d1b6b
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150806.195600
Firmware Date          Thu Aug  6 19:56:08 UTC 2015
Bootloader             s1
Blocks: 1181927
This issue cannot be reproduced on latest FlameKK master, AriesKK v2.5&master build by the same STR in comment 0.
Actual result:"Call Ended" and call time are displayed properly on the conference call view.
See attachment:Call end_v2.5&master.png.
Reproducing rate:0/5

FlameKK v2.5 build(512mb):
Build ID               20151102004502
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/b6b410d4610da18f5e43750e67ed2c56a0c0f812
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151102.042848
Firmware Date          Mon Nov  2 04:29:02 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

FlameKK master build(512mb):
Build ID               20151102150204
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6275cd9c71b76891f6b6585dabc687bc443ab877
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151102.182914
Firmware Date          Mon Nov  2 18:29:28 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: AriesKK master build:
Build ID               20151103000930
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9f69202d82752e093a653a8f15b0274e347db33a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151102.233051
Firmware Date          Mon Nov  2 23:30:58 UTC 2015
Bootloader             s1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.