If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Dialer] The + sign and country code is not displayed on callscreen when receiving a second incoming call

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P3
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: YeojinC, Assigned: drs)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8589383 [details]
2ndIncomingArabic.png

Description:
A contact saved with + and the country code is displayed correctly with the + sign and the country code on the callscreen. However, the + sign and country code of the incoming call are missed on the callscreen when there is an existing call on the device. 

Pre-requisite: Have a contact with + and country code in the phone number.

Repro Steps:
1) Update a Flame to 20150407010204.
2) Receive an incoming call, and answer the call.
3) With the active call, receive another call from a contact saved with + and the area code.
4) Observe the contact appearing on the callscreen.

Actual:
+ and the country code are missing.

Expected:
+ and the country code are displayed as saved with the contact.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150407010204
Gaia: c710bac533b76635161315bf907d004e000549cb
Gecko: ab0490972e1e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 5/5
See attached: screenshot
(Reporter)

Comment 1

3 years ago
This issue does NOT reproduce on Flame 2.2.

Result: + and the country code are displayed as saved with the contact.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
BuildID: 20150407002501
Gaia: 5e09637414269728f6f1bc0152d0160f3b6b380e
Gecko: 245f37f44017
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Updated

3 years ago
See Also: → bug 1150953
[Blocking Requested - why for this release]:

This is a regression from 2.2 so nominating this 3.0?
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
I can't repro on master with this specific gaia revision[1]. I wonder if it's because because French carriers display the + sign in calls, unlike AT&T.

This is likely due to bug 1150953 which hasn't been uplifted yet. 

[1] Build ID               20150407010204
Gaia Revision          a290b11627ec2b7c25980f5687a98da86641cfe4
Gaia Date              2015-04-08 08:26:08
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ab0490972e1e
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.044416
Firmware Date          Tue Apr  7 04:44:28 EDT 2015
Bootloader             L1TC000118D0
QA Contact: onelson
(Reporter)

Updated

3 years ago
QA Contact: onelson → ychung
(Reporter)

Comment 4

3 years ago
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150406101001
Gaia: 689ab15d34c8d41182e0f83ebe59832fa4bba9e2
Gecko: a24477231f69
Version: 40.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150406104600
Gaia: b8508bbf73756e61ac1c4281c5f2595cedb6b173
Gecko: d057d3ff15a8
Version: 40.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 689ab15d34c8d41182e0f83ebe59832fa4bba9e2
Gecko: d057d3ff15a8

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: b8508bbf73756e61ac1c4281c5f2595cedb6b173
Gecko: a24477231f69

https://github.com/mozilla-b2g/gaia/compare/689ab15d34c8d41182e0f83ebe59832fa4bba9e2...b8508bbf73756e61ac1c4281c5f2595cedb6b173

Caused by bug 1150953
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
Douglas, can you take a look at this please? This looks to have been caused by the landing for bug 1150953.
Blocks: 1150953
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(drs)
(Assignee)

Comment 6

3 years ago
Redirecting to Tamara and Gabriele.
Flags: needinfo?(thills)
Flags: needinfo?(gsvelto)
Flags: needinfo?(drs)
Comms triage: Regression.
blocking-b2g: 3.0? → 3.0+
Assignee: nobody → gsvelto
Flags: needinfo?(gsvelto)
(Assignee)

Updated

2 years ago
Assignee: gsvelto → drs
Priority: -- → P3
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
Flags: needinfo?(thills)
(Assignee)

Comment 8

2 years ago
Created attachment 8666107 [details]
Screenshot with functionality working as expected.

I'm unable to repro this bug on the latest master/m-c. See the attached screenshot.

There's another bug I notice though, that the contact name is left-aligned instead of right-aligned on the second incoming call panel. I've filed bug 1208558 for this.
(Assignee)

Comment 9

2 years ago
Please check if this can still be reproduced.
Status: ASSIGNED → NEW
Keywords: qawanted
This bug can be repro on the latest build of Flame KK v2.5&Aries KK v2.5 by the STR in comment 0.

Actual results: + and the country code are missing.

See Attachment: Flame_KK_v2.5.png&logcat_0422.txt
Found Time: 0422

Reproduce rate: 10/10

Device: Flame KK v2.5
Build ID               20150927150205
Gaia Revision          285486b417f1cb8316b19c0698a6655fc053fbd6
Gaia Date              2015-09-25 14:11:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6256ec9113c115141aab089c45ee69438884b680
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150927.184956
Firmware Date          Sun Sep 27 18:50:08 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5
Build ID               20150927001555
Gaia Revision          285486b417f1cb8316b19c0698a6655fc053fbd6
Gaia Date              2015-09-25 14:11:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6256ec9113c115141aab089c45ee69438884b680
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150926.233607
Firmware Date          Sat Sep 26 23:36:15 UTC 2015
Bootloader             s1
Keywords: qawanted
Created attachment 8666617 [details]
Flame KK v2.5.png
Created attachment 8666618 [details]
logcat_0422.txt
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(drs)
Created attachment 8670665 [details]
Current screenshot

I've tested this again with today's master build and I can't see the issue anymore, see the attached screenshot. I've tried reproducing the exact situation which was described before guessing the full numbers from the screenshot.
Closing as WFM, please reopen if you encounter this problem again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(drs)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.